The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / bustle / bustle.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/bustle/bustle.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/bustle/bustle.mk
new file mode 100644 (file)
index 0000000..1ba36e0
--- /dev/null
@@ -0,0 +1,28 @@
+################################################################################
+#
+# bustle
+#
+################################################################################
+
+BUSTLE_VERSION = 0.4.3
+BUSTLE_SITE = http://www.willthompson.co.uk/bustle/releases/$(BUSTLE_VERSION)
+BUSTLE_LICENSE = LGPLv2.1+
+BUSTLE_LICENSE_FILES = LICENSE
+BUSTLE_DEPENDENCIES = libglib2 libpcap host-pkgconf
+
+BUSTLE_PCAP_FLAGS = "-lpcap"
+ifeq ($(BR2_STATIC_LIBS),y)
+BUSTLE_PCAP_FLAGS += $(shell $(STAGING_DIR)/usr/bin/pcap-config --static --additional-libs)
+endif
+
+define BUSTLE_BUILD_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) \
+               PCAP_FLAGS="$(BUSTLE_PCAP_FLAGS)" -C $(@D) dist/build/bustle-pcap
+endef
+
+define BUSTLE_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0755 -D $(@D)/dist/build/bustle-pcap \
+               $(TARGET_DIR)/usr/bin/bustle-pcap
+endef
+
+$(eval $(generic-package))