The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / bootstrap / bootstrap.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/bootstrap/bootstrap.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/bootstrap/bootstrap.mk
new file mode 100644 (file)
index 0000000..17752ce
--- /dev/null
@@ -0,0 +1,26 @@
+################################################################################
+#
+# bootstrap
+#
+################################################################################
+
+BOOTSTRAP_VERSION = 3.3.1
+BOOTSTRAP_SITE = https://github.com/twbs/bootstrap/releases/download/v$(BOOTSTRAP_VERSION)
+BOOTSTRAP_SOURCE = bootstrap-$(BOOTSTRAP_VERSION)-dist.zip
+BOOTSTRAP_LICENSE = MIT
+
+define BOOTSTRAP_EXTRACT_CMDS
+       $(UNZIP) $(DL_DIR)/$(BOOTSTRAP_SOURCE) -d $(@D)
+endef
+
+define BOOTSTRAP_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0644 -D $(@D)/dist/css/bootstrap-theme.min.css \
+               $(TARGET_DIR)/var/www/bootstrap/css/bootstrap-theme.min.css
+       $(INSTALL) -m 0644 -D $(@D)/dist/css/bootstrap.min.css \
+               $(TARGET_DIR)/var/www/bootstrap/css/bootstrap.min.css
+       $(INSTALL) -m 0644 -D $(@D)/dist/js/bootstrap.min.js \
+               $(TARGET_DIR)/var/www/bootstrap/js/bootstrap.min.js
+       cp -r $(@D)/dist/fonts $(TARGET_DIR)/var/www/bootstrap/
+endef
+
+$(eval $(generic-package))