The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / boa / boa.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/boa/boa.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/boa/boa.mk
new file mode 100644 (file)
index 0000000..ab23d90
--- /dev/null
@@ -0,0 +1,19 @@
+################################################################################
+#
+# boa
+#
+################################################################################
+
+BOA_VERSION = 0.94.14rc21
+BOA_SITE = http://www.boa.org
+BOA_LICENSE = GPLv2+
+BOA_LICENSE_FILES = COPYING
+
+define BOA_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 755 $(@D)/src/boa $(TARGET_DIR)/usr/sbin/boa
+       $(INSTALL) -D -m 755 $(@D)/src/boa_indexer $(TARGET_DIR)/usr/lib/boa/boa_indexer
+       $(INSTALL) -D -m 644 package/boa/boa.conf $(TARGET_DIR)/etc/boa/boa.conf
+       $(INSTALL) -D -m 644 package/boa/mime.types $(TARGET_DIR)/etc/mime.types
+endef
+
+$(eval $(autotools-package))