The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / bmon / bmon.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/bmon/bmon.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/bmon/bmon.mk
new file mode 100644 (file)
index 0000000..e430bf6
--- /dev/null
@@ -0,0 +1,21 @@
+################################################################################
+#
+# bmon
+#
+################################################################################
+
+BMON_VERSION = 3.6
+BMON_SITE = https://github.com/tgraf/bmon/releases/download/v$(BMON_VERSION)
+BMON_DEPENDENCIES = host-pkgconf libconfuse libnl ncurses
+BMON_LICENSE = BSD-2c, MIT
+BMON_LICENSE_FILES = LICENSE.BSD LICENSE.MIT
+
+# link dynamically unless explicitly requested otherwise
+ifeq ($(BR2_STATIC_LIBS),)
+BMON_CONF_OPTS += --disable-static
+else
+# forgets to explicitly link with pthread for libnl
+BMON_CONF_OPTS += LIBS=-lpthread
+endif
+
+$(eval $(autotools-package))