The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / blackbox / blackbox.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/blackbox/blackbox.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/blackbox/blackbox.mk
new file mode 100644 (file)
index 0000000..a73bc5b
--- /dev/null
@@ -0,0 +1,23 @@
+################################################################################
+#
+# blackbox
+#
+################################################################################
+
+BLACKBOX_VERSION = 0.70.1
+BLACKBOX_SOURCE = blackbox-$(BLACKBOX_VERSION).tar.bz2
+BLACKBOX_SITE = http://downloads.sourceforge.net/project/blackboxwm/blackboxwm/Blackbox%20$(BLACKBOX_VERSION)
+BLACKBOX_CONF_OPTS = \
+       --x-includes=$(STAGING_DIR)/usr/include/X11 \
+       --x-libraries=$(STAGING_DIR)/usr/lib
+BLACKBOX_DEPENDENCIES = xlib_libX11
+BLACKBOX_LICENSE = MIT
+BLACKBOX_LICENSE_FILES = LICENSE
+
+ifneq ($(BR2_ENABLE_LOCALE),y)
+BLACKBOX_DEPENDENCIES += libiconv
+endif
+
+BLACKBOX_AUTORECONF = YES
+
+$(eval $(autotools-package))