The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / batctl / batctl.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/batctl/batctl.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/batctl/batctl.mk
new file mode 100644 (file)
index 0000000..c458752
--- /dev/null
@@ -0,0 +1,21 @@
+################################################################################
+#
+# batctl
+#
+################################################################################
+
+BATCTL_VERSION = 2014.4.0
+BATCTL_SITE = http://downloads.open-mesh.org/batman/releases/batman-adv-$(BATCTL_VERSION)
+BATCTL_LICENSE = GPLv2
+BATCTL_DEPENDENCIES = libnl host-pkgconf
+
+define BATCTL_BUILD_CMDS
+       $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) all
+endef
+
+define BATCTL_INSTALL_TARGET_CMDS
+       $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
+               PREFIX=/usr DESTDIR=$(TARGET_DIR) install
+endef
+
+$(eval $(generic-package))