The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / axel / axel.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/axel/axel.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/axel/axel.mk
new file mode 100644 (file)
index 0000000..6328d99
--- /dev/null
@@ -0,0 +1,41 @@
+################################################################################
+#
+# axel
+#
+################################################################################
+
+AXEL_VERSION = 2.4
+AXEL_SITE = http://sources.buildroot.net
+AXEL_LICENSE = GPLv2+
+AXEL_LICENSE_FILES = COPYING
+
+AXEL_LDFLAGS = -lpthread
+
+ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
+AXEL_DEPENDENCIES += gettext
+AXEL_LDFLAGS += -lintl
+endif
+
+ifneq ($(BR2_ENABLE_LOCALE),y)
+AXEL_DISABLE_I18N = --i18n=0
+endif
+
+define AXEL_CONFIGURE_CMDS
+       (cd $(@D); \
+               ./configure \
+                       --prefix=/usr \
+                       --debug=1 \
+                       $(AXEL_DISABLE_I18N) \
+       )
+endef
+
+define AXEL_BUILD_CMDS
+       $(MAKE) CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" \
+       LFLAGS="$(TARGET_LDFLAGS) $(AXEL_LDFLAGS)" -C $(@D)
+endef
+
+define AXEL_INSTALL_TARGET_CMDS
+       $(MAKE) DESTDIR=$(TARGET_DIR) -C $(@D) install
+endef
+
+$(eval $(generic-package))