The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / automake / automake.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/automake/automake.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/automake/automake.mk
new file mode 100644 (file)
index 0000000..a3fd18c
--- /dev/null
@@ -0,0 +1,33 @@
+################################################################################
+#
+# automake
+#
+################################################################################
+
+AUTOMAKE_VERSION = 1.15
+AUTOMAKE_SOURCE = automake-$(AUTOMAKE_VERSION).tar.xz
+AUTOMAKE_SITE = $(BR2_GNU_MIRROR)/automake
+AUTOMAKE_LICENSE = GPLv2+
+AUTOMAKE_LICENSE_FILES = COPYING
+
+HOST_AUTOMAKE_DEPENDENCIES = host-autoconf
+
+define GTK_DOC_M4_INSTALL
+       $(INSTALL) -D -m 0644 package/automake/gtk-doc.m4 $(HOST_DIR)/usr/share/aclocal/gtk-doc.m4
+endef
+
+# ensure staging aclocal dir exists
+define HOST_AUTOMAKE_MAKE_ACLOCAL
+       mkdir -p $(ACLOCAL_DIR)
+endef
+
+HOST_AUTOMAKE_POST_INSTALL_HOOKS += GTK_DOC_M4_INSTALL
+HOST_AUTOMAKE_POST_INSTALL_HOOKS += HOST_AUTOMAKE_MAKE_ACLOCAL
+
+$(eval $(host-autotools-package))
+
+# variables used by other packages
+AUTOMAKE = $(HOST_DIR)/usr/bin/automake
+ACLOCAL_DIR = $(STAGING_DIR)/usr/share/aclocal
+ACLOCAL_HOST_DIR = $(HOST_DIR)/usr/share/aclocal
+ACLOCAL = $(HOST_DIR)/usr/bin/aclocal -I $(ACLOCAL_DIR)