The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / audiofile / audiofile.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/audiofile/audiofile.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/audiofile/audiofile.mk
new file mode 100644 (file)
index 0000000..c685ce1
--- /dev/null
@@ -0,0 +1,25 @@
+################################################################################
+#
+# audiofile
+#
+################################################################################
+
+AUDIOFILE_VERSION = 0.3.6
+AUDIOFILE_SITE = http://audiofile.68k.org
+AUDIOFILE_INSTALL_STAGING = YES
+AUDIOFILE_CONF_ENV = ac_cv_prog_cc_c99='-std=gnu99'
+AUDIOFILE_CONF_OPTS = --disable-examples
+AUDIOFILE_DEPENDENCIES = host-pkgconf
+# configure is outdated and has old bugs because of it
+AUDIOFILE_AUTORECONF = YES
+AUDIOFILE_LICENSE = GPLv2+ LGPLv2.1+
+AUDIOFILE_LICENSE_FILES = COPYING COPYING.GPL
+
+ifeq ($(BR2_PACKAGE_FLAC),y)
+AUDIOFILE_DEPENDENCIES += flac
+AUDIOFILE_CONF_OPTS += --enable-flac
+else
+AUDIOFILE_CONF_OPTS += --disable-flac
+endif
+
+$(eval $(autotools-package))