The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / atftp / atftp.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/atftp/atftp.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/atftp/atftp.mk
new file mode 100644 (file)
index 0000000..4d9a71b
--- /dev/null
@@ -0,0 +1,32 @@
+################################################################################
+#
+# atftp
+#
+################################################################################
+
+ATFTP_VERSION = 0.7.1
+ATFTP_SITE = http://sourceforge.net/projects/atftp/files
+ATFTP_LICENSE = GPLv2+
+ATFTP_LICENSE_FILES = LICENSE
+ATFTP_CONF_OPTS = --disable-libwrap --disable-mtftp
+# For static we need to explicitly link against libpthread
+ATFTP_LIBS = -lpthread
+ATFTP_CONF_ENV = LIBS="$(ATFTP_LIBS)"
+
+ifeq ($(BR2_PACKAGE_READLINE),y)
+ATFTP_DEPENDENCIES += readline
+ATFTP_CONF_OPTS += --enable-libreadline
+# For static, readline links with ncurses
+ATFTP_LIBS += -lncurses
+else
+ATFTP_CONF_OPTS += --disable-libreadline
+endif
+
+ifeq ($(BR2_PACKAGE_PCRE),y)
+ATFTP_DEPENDENCIES += pcre
+ATFTP_CONF_OPTS += --enable-libpcre
+else
+ATFTP_CONF_OPTS += --disable-libpcre
+endif
+
+$(eval $(autotools-package))