The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / atftp / 0001-Makefile.am-link-against-libpthread-for-atftp.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/atftp/0001-Makefile.am-link-against-libpthread-for-atftp.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/atftp/0001-Makefile.am-link-against-libpthread-for-atftp.patch
new file mode 100644 (file)
index 0000000..e879df5
--- /dev/null
@@ -0,0 +1,26 @@
+Makefile.am: link against libpthread for atftp
+
+atftp client needs to link against libpthread as static builds do not
+work otherwise.
+
+Signed-off-by: Ryan Barnett <ryan.barnett@rockwellcollins.com>
+---
+ Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index e59592f..200829a 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -28,7 +28,7 @@ noinst_HEADERS   = argz.h logger.h options.h stats.h tftp.h tftp_def.h tftp_io.h
+                  tftpd.h tftpd_pcre.h tftpd_mtftp.h
+ bin_PROGRAMS     = atftp
+-atftp_LDADD      = $(LIBTERMCAP) $(LIBREADLINE)
++atftp_LDADD      = $(LIBTERMCAP) $(LIBREADLINE) $(LIBPTHREAD)
+ atftp_SOURCES    = tftp.c tftp_io.c logger.c options.c tftp_def.c tftp_file.c \
+                  argz.c tftp_mtftp.c
+-- 
+1.9.1
+