The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / arptables / arptables.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/arptables/arptables.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/arptables/arptables.mk
new file mode 100644 (file)
index 0000000..4f101c7
--- /dev/null
@@ -0,0 +1,21 @@
+################################################################################
+#
+# arptables
+#
+################################################################################
+
+ARPTABLES_VERSION = 0.0.4
+ARPTABLES_SOURCE = arptables-v$(ARPTABLES_VERSION).tar.gz
+ARPTABLES_SITE = http://downloads.sourceforge.net/project/ebtables/arptables/arptables-v$(ARPTABLES_VERSION)
+ARPTABLES_LICENSE = GPLv2+
+
+define ARPTABLES_BUILD_CMDS
+       $(MAKE) -C $(@D) \
+               CC="$(TARGET_CC)" COPT_FLAGS="$(TARGET_CFLAGS)"
+endef
+
+define ARPTABLES_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 755 -D $(@D)/arptables $(TARGET_DIR)/usr/sbin/arptables
+endef
+
+$(eval $(generic-package))