The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / argp-standalone / argp-standalone.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/argp-standalone/argp-standalone.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/argp-standalone/argp-standalone.mk
new file mode 100644 (file)
index 0000000..b87b923
--- /dev/null
@@ -0,0 +1,25 @@
+################################################################################
+#
+# argp-standalone
+#
+################################################################################
+
+ARGP_STANDALONE_VERSION = 1.3
+ARGP_STANDALONE_SITE = http://www.lysator.liu.se/~nisse/archive
+ARGP_STANDALONE_INSTALL_STAGING = YES
+ARGP_STANDALONE_LICENSE = LGPLv2+
+
+ARGP_STANDALONE_CONF_ENV = \
+       CFLAGS="$(TARGET_CFLAGS) -fPIC"
+
+define ARGP_STANDALONE_INSTALL_STAGING_CMDS
+       $(INSTALL) -D $(@D)/libargp.a $(STAGING_DIR)/usr/lib/libargp.a
+       $(INSTALL) -D $(@D)/argp.h $(STAGING_DIR)/usr/include/argp.h
+endef
+
+define ARGP_STANDALONE_INSTALL_TARGET_CMDS
+       $(INSTALL) -D $(@D)/libargp.a $(TARGET_DIR)/usr/lib/libargp.a
+       $(INSTALL) -D $(@D)/argp.h $(TARGET_DIR)/usr/include/argp.h
+endef
+
+$(eval $(autotools-package))