The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / am33x-cm3 / 0001-fix-makefile.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/am33x-cm3/0001-fix-makefile.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/am33x-cm3/0001-fix-makefile.patch
new file mode 100644 (file)
index 0000000..f3cdb5e
--- /dev/null
@@ -0,0 +1,30 @@
+Enforce correct -march option
+
+Buildroot uses a normal ARM compiler to build the AM33X CM3 firmware
+(which runs on a Cortex-M3 processor), but Buildroot will have a
+default -march value that doesn't necessarily match the one needed for
+Cortex-M3, leading to build failures (gcc complains that the
+-mcpu=cortex-m3 option being passed is not compatible with the
+selected -march).
+
+Fix this by explicitly indicating -march=armv7-m.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Updated the patch to the latest version of the Makefile
+
+Signed-off-by: Anders Darander <anders@chargestorm.se>
+
+Index: b/Makefile
+===================================================================
+--- a/Makefile
++++ b/Makefile
+@@ -13,7 +13,7 @@ SRCDIR = src
+ BINDIR = bin
+ INCLUDES = $(SRCDIR)/include
+-CFLAGS =-mcpu=cortex-m3 -mthumb -nostdlib -Wall -Wundef \
++CFLAGS =-march=armv7-m -mcpu=cortex-m3 -mthumb -nostdlib -Wall -Wundef \
+       -Werror-implicit-function-declaration -Wstrict-prototypes \
+       -Wdeclaration-after-statement -fno-delete-null-pointer-checks \
+       -Wempty-body -fno-strict-overflow  -g -I$(INCLUDES) -O2