The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / aiccu / 0003-clock-suite-functions-fix.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/aiccu/0003-clock-suite-functions-fix.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/aiccu/0003-clock-suite-functions-fix.patch
new file mode 100644 (file)
index 0000000..365e72a
--- /dev/null
@@ -0,0 +1,18 @@
+aiccu: fix undefined reference to clock_* functions
+
+Since glibc 2.17 the clock_* suite functions are available directly in 
+the main C library. For previous versions we still need -lrt to link.
+
+Signed-off-by: Vicente Olivert Riera <vincent.riera@imgtec.com>
+
+--- aiccu/unix-console/Makefile.orig   2014-01-14 10:17:20.204602513 +0000
++++ aiccu/unix-console/Makefile        2014-01-14 10:17:31.435777359 +0000
+@@ -42,7 +42,7 @@ CFLAGS       += -D AICCU_CONSOLE
+ # Currently defaultly builds only on Linux, but other platforms might easily also support it
+ ifeq ($(shell uname | grep -c "Linux"),1)
+ CFLAGS        += -D AICCU_GNUTLS
+-LDFLAGS += -lgnutls
++LDFLAGS += -lgnutls -lrt
+ endif
+ # Linux