The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / aiccu / 0002-makefile-reorder-linked-libraries.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/aiccu/0002-makefile-reorder-linked-libraries.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/aiccu/0002-makefile-reorder-linked-libraries.patch
new file mode 100644 (file)
index 0000000..22f04a9
--- /dev/null
@@ -0,0 +1,15 @@
+Makefile: change LDFLAGS order on the compile line for --static
+
+Signed-off-by: Michael Rommel <rommel@layer-7.net>
+
+--- aiccu_20070115.orig/unix-console/Makefile  2007-01-15 12:04:27.000000000 +0100
++++ aiccu_20070115/unix-console/Makefile       2013-09-29 22:54:42.742963861 +0200
+@@ -144,7 +144,7 @@ endif
+ all: aiccu
+ aiccu:        $(OBJS) ${SRCS} ${INCS}
+-      $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJS)
++      $(CC) $(CFLAGS) -o $@ $(OBJS) $(LDFLAGS)
+ ifeq ($(shell echo $(CFLAGS) | grep -c "DEBUG"),0)
+ ifeq ($(shell echo "$(RPM_OPT_FLAGS)" | wc -c),1)
+       strip $@