The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / linux / linux-ext-fbtft.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/linux/linux-ext-fbtft.mk b/cirros-testvm/src-cirros/buildroot-2015.05/linux/linux-ext-fbtft.mk
new file mode 100644 (file)
index 0000000..5eb3d94
--- /dev/null
@@ -0,0 +1,22 @@
+################################################################################
+# Linux fbtft extensions
+#
+# Patch the linux kernel with fbtft extension
+################################################################################
+
+LINUX_EXTENSIONS += fbtft
+
+# for linux >= 3.15 install to drivers/video/fbdev/fbtft
+# for linux < 3.15 install to drivers/video/fbtft
+define FBTFT_PREPARE_KERNEL
+       if [ -e $(LINUX_DIR)/drivers/video/fbdev ]; then \
+               dest=drivers/video/fbdev ; \
+       else \
+               dest=drivers/video ; \
+       fi ; \
+       mkdir -p $(LINUX_DIR)/$${dest}/fbtft; \
+       cp -dpfr $(FBTFT_DIR)/* $(LINUX_DIR)/$${dest}/fbtft/ ; \
+       echo "source \"$${dest}/fbtft/Kconfig\"" \
+               >> $(LINUX_DIR)/$${dest}/Kconfig ; \
+       echo 'obj-y += fbtft/' >> $(LINUX_DIR)/$${dest}/Makefile
+endef