The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / fs / squashfs / squashfs.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/fs/squashfs/squashfs.mk b/cirros-testvm/src-cirros/buildroot-2015.05/fs/squashfs/squashfs.mk
new file mode 100644 (file)
index 0000000..446906f
--- /dev/null
@@ -0,0 +1,33 @@
+################################################################################
+#
+# Build the squashfs root filesystem image
+#
+################################################################################
+
+ROOTFS_SQUASHFS_DEPENDENCIES = host-squashfs
+
+ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4_LZ4),y)
+ROOTFS_SQUASHFS_ARGS += -comp lz4
+else
+ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4_LZO),y)
+ROOTFS_SQUASHFS_ARGS += -comp lzo
+else
+ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4_LZMA),y)
+ROOTFS_SQUASHFS_ARGS += -comp lzma
+else
+ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4_XZ),y)
+ROOTFS_SQUASHFS_ARGS += -comp xz
+else
+ROOTFS_SQUASHFS_ARGS += -comp gzip
+endif
+endif
+endif
+endif
+
+define ROOTFS_SQUASHFS_CMD
+       $(HOST_DIR)/usr/bin/mksquashfs $(TARGET_DIR) $@ -noappend \
+               $(ROOTFS_SQUASHFS_ARGS) && \
+       chmod 0644 $@
+endef
+
+$(eval $(call ROOTFS_TARGET,squashfs))