The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / fs / initramfs / initramfs.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/fs/initramfs/initramfs.mk b/cirros-testvm/src-cirros/buildroot-2015.05/fs/initramfs/initramfs.mk
new file mode 100644 (file)
index 0000000..db50812
--- /dev/null
@@ -0,0 +1,24 @@
+################################################################################
+#
+# Build a kernel with an integrated initial ramdisk
+# filesystem based on cpio.
+#
+################################################################################
+
+ROOTFS_INITRAMFS_DEPENDENCIES += rootfs-cpio
+
+ROOTFS_INITRAMFS_POST_TARGETS += linux-rebuild-with-initramfs
+
+
+# The generic fs infrastructure isn't very useful here.
+
+rootfs-initramfs: $(ROOTFS_INITRAMFS_DEPENDENCIES) $(ROOTFS_INITRAMFS_POST_TARGETS)
+
+rootfs-initramfs-show-depends:
+       @echo $(ROOTFS_INITRAMFS_DEPENDENCIES)
+
+.PHONY: rootfs-initramfs rootfs-initramfs-show-depends
+
+ifeq ($(BR2_TARGET_ROOTFS_INITRAMFS),y)
+TARGETS_ROOTFS += rootfs-initramfs
+endif