The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / build / docs / manual / manual.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/build/docs/manual/manual.mk b/cirros-testvm/src-cirros/buildroot-2015.05/build/docs/manual/manual.mk
new file mode 100644 (file)
index 0000000..ad9bd90
--- /dev/null
@@ -0,0 +1,34 @@
+################################################################################
+#
+# The Buildroot manual
+#
+################################################################################
+
+MANUAL_SOURCES = $(sort $(wildcard docs/manual/*.txt) $(wildcard docs/images/*))
+MANUAL_RESOURCES = $(TOPDIR)/docs/images
+
+# Our manual needs to generate lists
+# Packages included in BR2_EXTERNAL are not part of buildroot, so they
+# should not be included in the manual.
+define MANUAL_GEN_LISTS
+       $(Q)$(call MESSAGE,"Updating the manual lists...")
+       $(Q)$(COMMON_CONFIG_ENV) \
+               BR2_DEFCONFIG="" \
+               BR2_EXTERNAL=$(TOPDIR)/support/dummy-external \
+               TOPDIR=$(TOPDIR) \
+               O=$(@D) \
+               python -B $(TOPDIR)/support/scripts/gen-manual-lists.py
+endef
+MANUAL_POST_RSYNC_HOOKS += MANUAL_GEN_LISTS
+
+# Our list-generating script requires argparse
+define MANUAL_CHECK_LISTS_DEPS
+       $(Q)if ! python -c "import argparse" >/dev/null 2>&1 ; then \
+               echo "You need python with argparse on your host to generate" \
+                       "the list of packages in the manual"; \
+               exit 1; \
+       fi
+endef
+MANUAL_CHECK_DEPENDENCIES_HOOKS += MANUAL_CHECK_LISTS_DEPS
+
+$(eval $(call asciidoc-document))