The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / boot / at91dataflashboot / at91dataflashboot.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/boot/at91dataflashboot/at91dataflashboot.mk b/cirros-testvm/src-cirros/buildroot-2015.05/boot/at91dataflashboot/at91dataflashboot.mk
new file mode 100644 (file)
index 0000000..0ad8b6f
--- /dev/null
@@ -0,0 +1,22 @@
+################################################################################
+#
+# at91dataflashboot
+#
+################################################################################
+
+AT91DATAFLASHBOOT_VERSION = 1.05
+AT91DATAFLASHBOOT_SOURCE = DataflashBoot-$(AT91DATAFLASHBOOT_VERSION).tar.bz2
+AT91DATAFLASHBOOT_SITE = ftp://www.at91.com/pub/buildroot
+
+AT91DATAFLASHBOOT_INSTALL_TARGET = NO
+AT91DATAFLASHBOOT_INSTALL_IMAGES = YES
+
+define AT91DATAFLASHBOOT_BUILD_CMDS
+       make -C $(@D) CROSS_COMPILE=$(TARGET_CROSS)
+endef
+
+define AT91DATAFLASHBOOT_INSTALL_IMAGES_CMDS
+       cp $(@D)/DataflashBoot-$(AT91DATAFLASHBOOT_VERSION).bin $(BINARIES_DIR)
+endef
+
+$(eval $(generic-package))