Revert "Revert "LP #1376600. Prepare Corosync 2.3.3 package""
[packages/centos6/corosync.git] / corosync.spec
1 # Conditionals
2 # Invoke "rpmbuild --without <feature>" or "rpmbuild --with <feature>"
3 # to disable or enable specific features
4 %bcond_with testagents
5 %bcond_with watchdog
6 %bcond_with monitoring
7 %bcond_without snmp
8 %bcond_without dbus
9 # no InfiniBand stack on s390(x)
10 %ifnarch s390 s390x
11 %bcond_with rdma
12 %endif
13 %bcond_with systemd
14 %bcond_without upstart
15 %bcond_without xmlconf
16 %bcond_without runautogen
17
18 %global gitver %{?numcomm:.%{numcomm}}%{?alphatag:.%{alphatag}}%{?dirty:.%{dirty}}
19 %global gittarver %{?numcomm:.%{numcomm}}%{?alphatag:-%{alphatag}}%{?dirty:-%{dirty}}
20
21 Name: corosync
22 Summary: The Corosync Cluster Engine and Application Programming Interfaces
23 Version: 2.3.3
24 Release: 2%{?gitver}%{?dist}
25 License: BSD
26 Group: System Environment/Base
27 URL: http://www.corosync.org/
28 Source0: http://corosync.org/download/%{name}-%{version}%{?gittarver}.tar.gz
29
30 Patch0: bz1067028-1-cpg-Refactor-mh_req_exec_cpg_procleave.patch
31 Patch1: bz1067028-2-cpg-Make-sure-nodid-is-always-logged-as-hex-num.patch
32 Patch2: bz1067028-3-cpg-Make-sure-left-nodes-are-really-removed.patch
33
34 %if 0%{?rhel}
35 ExclusiveArch: i686 x86_64
36 %endif
37
38 # Runtime bits
39 Requires: corosynclib = %{version}-%{release}
40 Requires(pre): /usr/sbin/useradd
41 Requires(post): /sbin/chkconfig
42 Requires(preun): /sbin/chkconfig
43 Obsoletes: openais, openais-devel, openaislib, openaislib-devel
44 Obsoletes: cman, clusterlib, clusterlib-devel
45
46 # Build bits
47
48 BuildRequires: groff
49 BuildRequires: libqb-devel >= 0.14.2
50 BuildRequires: nss-devel
51 %if %{with runautogen}
52 BuildRequires: autoconf automake libtool
53 %endif
54 %if %{with monitoring}
55 BuildRequires: libstatgrab-devel
56 %endif
57 %if %{with rdma}
58 BuildRequires: libibverbs-devel librdmacm-devel
59 %endif
60 %if %{with snmp}
61 BuildRequires: net-snmp-devel
62 %endif
63 %if %{with dbus}
64 BuildRequires: dbus-devel
65 %endif
66 %if %{with systemd}
67 BuildRequires: systemd-units
68 Requires(post): systemd
69 Requires(preun): systemd
70 Requires(postun): systemd
71 %endif
72 %if %{with xmlconf}
73 Requires: libxslt
74 %endif
75
76 BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
77
78 %prep
79 %setup -q -n %{name}-%{version}%{?gittarver}
80 %patch0 -p1 -b .bz1067028-1
81 %patch1 -p1 -b .bz1067028-2
82 %patch2 -p1 -b .bz1067028-3
83
84 %build
85 %if %{with runautogen}
86 ./autogen.sh
87 %endif
88
89 %if %{with rdma}
90 export ibverbs_CFLAGS=-I/usr/include/infiniband \
91 export ibverbs_LIBS=-libverbs \
92 export rdmacm_CFLAGS=-I/usr/include/rdma \
93 export rdmacm_LIBS=-lrdmacm \
94 %endif
95 %{configure} \
96 %if %{with testagents}
97         --enable-testagents \
98 %endif
99 %if %{with watchdog}
100         --enable-watchdog \
101 %endif
102 %if %{with monitoring}
103         --enable-monitoring \
104 %endif
105 %if %{with snmp}
106         --enable-snmp \
107 %endif
108 %if %{with dbus}
109         --enable-dbus \
110 %endif
111 %if %{with rdma}
112         --enable-rdma \
113 %endif
114 %if %{with systemd}
115         --enable-systemd \
116 %endif
117 %if %{with upstart}
118         --enable-upstart \
119 %endif
120 %if %{with xmlconf}
121         --enable-xmlconf \
122 %endif
123         --with-initddir=%{_initrddir} \
124         --with-systemddir=%{_unitdir} \
125         --with-upstartdir=%{_sysconfdir}/init
126
127 make %{_smp_mflags}
128
129 %install
130 rm -rf %{buildroot}
131
132 make install DESTDIR=%{buildroot}
133
134 %if %{with dbus}
135 mkdir -p -m 0700 %{buildroot}/%{_sysconfdir}/dbus-1/system.d
136 install -m 644 %{_builddir}/%{name}-%{version}%{?gittarver}/conf/corosync-signals.conf %{buildroot}/%{_sysconfdir}/dbus-1/system.d/corosync-signals.conf
137 %endif
138
139 ## tree fixup
140 # drop static libs
141 rm -f %{buildroot}%{_libdir}/*.a
142 rm -f %{buildroot}%{_libdir}/*.la
143 # drop docs and html docs for now
144 rm -rf %{buildroot}%{_docdir}/*
145 # /etc/sysconfig/corosync-notifyd
146 mkdir -p %{buildroot}%{_sysconfdir}/sysconfig
147 install -m 644 tools/corosync-notifyd.sysconfig.example \
148    %{buildroot}%{_sysconfdir}/sysconfig/corosync-notifyd
149
150 %clean
151 rm -rf %{buildroot}
152
153 %description
154 This package contains the Corosync Cluster Engine Executive, several default
155 APIs and libraries, default configuration files, and an init script.
156
157 %post
158 %if %{with systemd} && 0%{?systemd_post:1}
159 %systemd_post corosync.service
160 %else
161 if [ $1 -eq 1 ]; then
162         /sbin/chkconfig --add corosync || :
163 fi
164 %endif
165
166 %preun
167 %if %{with systemd} && 0%{?systemd_preun:1}
168 %systemd_preun corosync.service
169 %else
170 if [ $1 -eq 0 ]; then
171         /sbin/service corosync stop &>/dev/null || :
172         /sbin/chkconfig --del corosync || :
173 fi
174 %endif
175
176 %postun
177 %if %{with systemd} && 0%{?systemd_postun:1}
178 %systemd_postun
179 %endif
180
181 %files
182 %defattr(-,root,root,-)
183 %doc LICENSE SECURITY
184 %{_sbindir}/corosync
185 %{_sbindir}/corosync-keygen
186 %{_sbindir}/corosync-cmapctl
187 %{_sbindir}/corosync-cfgtool
188 %{_sbindir}/corosync-cpgtool
189 %{_sbindir}/corosync-quorumtool
190 %{_sbindir}/corosync-notifyd
191 %{_bindir}/corosync-blackbox
192 %if %{with xmlconf}
193 %{_bindir}/corosync-xmlproc
194 %config(noreplace) %{_sysconfdir}/corosync/corosync.xml.example
195 %dir %{_datadir}/corosync
196 %{_datadir}/corosync/xml2conf.xsl
197 %{_mandir}/man8/corosync-xmlproc.8*
198 %{_mandir}/man5/corosync.xml.5*
199 %endif
200 %dir %{_sysconfdir}/corosync
201 %dir %{_sysconfdir}/corosync/uidgid.d
202 %config(noreplace) %{_sysconfdir}/corosync/corosync.conf.example
203 %config(noreplace) %{_sysconfdir}/corosync/corosync.conf.example.udpu
204 %config(noreplace) %{_sysconfdir}/sysconfig/corosync-notifyd
205 %if %{with dbus}
206 %{_sysconfdir}/dbus-1/system.d/corosync-signals.conf
207 %endif
208 %if %{with snmp}
209 %{_datadir}/snmp/mibs/COROSYNC-MIB.txt
210 %endif
211 %if %{with systemd}
212 %{_unitdir}/corosync.service
213 %{_unitdir}/corosync-notifyd.service
214 %dir %{_datadir}/corosync
215 %{_datadir}/corosync/corosync
216 %{_datadir}/corosync/corosync-notifyd
217 %else
218 %{_initrddir}/corosync
219 %{_initrddir}/corosync-notifyd
220 %endif
221 %if %{with upstart}
222 %{_sysconfdir}/init/corosync.conf
223 %{_sysconfdir}/init/corosync-notifyd.conf
224 %endif
225 %dir %{_localstatedir}/lib/corosync
226 %dir %{_localstatedir}/log/cluster
227 %{_mandir}/man8/corosync_overview.8*
228 %{_mandir}/man8/corosync.8*
229 %{_mandir}/man8/corosync-blackbox.8*
230 %{_mandir}/man8/corosync-cmapctl.8*
231 %{_mandir}/man8/corosync-keygen.8*
232 %{_mandir}/man8/corosync-cfgtool.8*
233 %{_mandir}/man8/corosync-cpgtool.8*
234 %{_mandir}/man8/corosync-notifyd.8*
235 %{_mandir}/man8/corosync-quorumtool.8*
236 %{_mandir}/man5/corosync.conf.5*
237 %{_mandir}/man5/votequorum.5*
238 %{_mandir}/man8/cmap_keys.8*
239
240 # optional testagent rpm
241 #
242 %if %{with testagents}
243
244 %package -n corosync-testagents
245 Summary: The Corosync Cluster Engine Test Agents
246 Group: Development/Libraries
247 Requires: %{name} = %{version}-%{release}
248 Requires: libqb >= 0.14.2
249
250 %description -n corosync-testagents
251 This package contains corosync test agents.
252
253 %files -n corosync-testagents
254 %defattr(755,root,root,-)
255 %{_datadir}/corosync/tests/mem_leak_test.sh
256 %{_datadir}/corosync/tests/net_breaker.sh
257 %{_datadir}/corosync/tests/cmap-dispatch-deadlock.sh
258 %{_datadir}/corosync/tests/shm_leak_audit.sh
259 %{_bindir}/cpg_test_agent
260 %{_bindir}/sam_test_agent
261 %{_bindir}/votequorum_test_agent
262
263 %endif
264
265 # library
266 #
267 %package -n corosynclib
268 Summary: The Corosync Cluster Engine Libraries
269 Group: System Environment/Libraries
270 Requires: %{name} = %{version}-%{release}
271
272 %description -n corosynclib
273 This package contains corosync libraries.
274
275 %files -n corosynclib
276 %defattr(-,root,root,-)
277 %doc LICENSE
278 %{_libdir}/libcfg.so.*
279 %{_libdir}/libcpg.so.*
280 %{_libdir}/libcmap.so.*
281 %{_libdir}/libtotem_pg.so.*
282 %{_libdir}/libquorum.so.*
283 %{_libdir}/libvotequorum.so.*
284 %{_libdir}/libsam.so.*
285 %{_libdir}/libcorosync_common.so.*
286
287 %post -n corosynclib -p /sbin/ldconfig
288
289 %postun -n corosynclib -p /sbin/ldconfig
290
291 %package -n corosynclib-devel
292 Summary: The Corosync Cluster Engine Development Kit
293 Group: Development/Libraries
294 Requires: corosynclib = %{version}-%{release}
295 Requires: pkgconfig
296 Provides: corosync-devel = %{version}
297 Obsoletes: corosync-devel < 0.92-7
298
299 %description -n corosynclib-devel
300 This package contains include files and man pages used to develop using
301 The Corosync Cluster Engine APIs.
302
303 %files -n corosynclib-devel
304 %defattr(-,root,root,-)
305 %doc LICENSE
306 %dir %{_includedir}/corosync/
307 %{_includedir}/corosync/corodefs.h
308 %{_includedir}/corosync/cfg.h
309 %{_includedir}/corosync/cmap.h
310 %{_includedir}/corosync/corotypes.h
311 %{_includedir}/corosync/cpg.h
312 %{_includedir}/corosync/hdb.h
313 %{_includedir}/corosync/sam.h
314 %{_includedir}/corosync/quorum.h
315 %{_includedir}/corosync/votequorum.h
316 %dir %{_includedir}/corosync/totem/
317 %{_includedir}/corosync/totem/totem.h
318 %{_includedir}/corosync/totem/totemip.h
319 %{_includedir}/corosync/totem/totempg.h
320 %{_libdir}/libcfg.so
321 %{_libdir}/libcpg.so
322 %{_libdir}/libcmap.so
323 %{_libdir}/libtotem_pg.so
324 %{_libdir}/libquorum.so
325 %{_libdir}/libvotequorum.so
326 %{_libdir}/libsam.so
327 %{_libdir}/libcorosync_common.so
328 %{_libdir}/pkgconfig/*.pc
329 %{_mandir}/man3/cpg_*3*
330 %{_mandir}/man3/quorum_*3*
331 %{_mandir}/man3/votequorum_*3*
332 %{_mandir}/man3/sam_*3*
333 %{_mandir}/man8/cpg_overview.8*
334 %{_mandir}/man8/votequorum_overview.8*
335 %{_mandir}/man8/sam_overview.8*
336 %{_mandir}/man3/cmap_*3*
337 %{_mandir}/man8/cmap_overview.8*
338 %{_mandir}/man8/quorum_overview.8*
339
340 %changelog
341 * Thu Feb 20 2014 Jan Friesse <jfriesse@redhat.com> 2.3.3-2
342 - Resolves: rhbz#1067028
343
344 - cpg: Refactor mh_req_exec_cpg_procleave (rhbz#1067028)
345 - merge upstream commit fcf26e03036b6ae5a8ef762ea0b5691a4f790c92 (rhbz#1067028)
346 - cpg: Make sure nodid is always logged as hex num (rhbz#1067028)
347 - merge upstream commit 83c63b247f4030fe8123df7c9f96d7a1c8e245b1 (rhbz#1067028)
348 - cpg: Make sure left nodes are really removed (rhbz#1067028)
349 - merge upstream commit fbe8768f1bbab6d546023d70e7f7b91a9dc213b0 (rhbz#1067028)
350
351 * Tue Jan 14 2014 Jan Friesse <jfriesse@redhat.com> - 2.3.3-1
352 - Resolves: rhbz#1030559
353 - Resolves: rhbz#1038652
354 - Resolves: rhbz#1052049
355
356 * Fri Dec 27 2013 Daniel Mach <dmach@redhat.com> - 2.3.2-4
357 - Mass rebuild 2013-12-27
358
359 * Wed Dec 04 2013 Jan Friesse <jfriesse@redhat.com> 2.3.2-3
360 - Resolves: rhbz#1031832
361
362 - cfgtool: return error on reload failure (rhbz#1031832)
363 - merge upstream commit 7014f10123a634cf026491edc9a09d6044106116 (rhbz#1031832)
364
365 * Thu Nov 7 2013 Jan Friesse <jfriesse@redhat.com> 2.3.2-2
366 - Resolves: rhbz#1008561
367
368 - Drop support for IBA (rhbz#1008561)
369
370 * Mon Sep 16 2013 Jan Friesse <jfriesse@redhat.com> - 2.3.2-1
371 - Resolves: rhbz#998882
372
373 - New upstream release
374
375 * Mon Aug 19 2013 Jan Friesse <jfriesse@redhat.com> 2.3.1-3
376 - Resolves: rhbz#998362
377
378 - Fix scheduler pause-detection timeout (rhbz#998362)
379 - merge upstream commit 2740cfd1eac60714601c74df2137fe588b607866 (rhbz#998362)
380
381 * Wed Jul 17 2013 Andrew Beekhof <abeekhof@redhat.com> - 2.3.1-2
382 - Rebuild for snmp library bump
383
384 * Wed Jul 10 2013 Jan Friesse <jfriesse@redhat.com> - 2.3.1-1
385 - New upstream release
386 - Fix incorrect dates in specfile changelog section
387
388 * Mon Mar 25 2013 Jan Friesse <jfriesse@redhat.com> - 2.3.0-3
389 - Resolves: rhbz#925185
390
391 - Run autogen by default
392
393 * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.0-2
394 - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
395
396 * Fri Jan 18 2013 Jan Friesse <jfriesse@redhat.com> - 2.3.0-1
397 - New upstream release
398
399 * Wed Dec 12 2012 Jan Friesse <jfriesse@redhat.com> - 2.2.0-1
400 - New upstream release
401
402 * Thu Oct 11 2012 Jan Friesse <jfriesse@redhat.com> - 2.1.0-1
403 - New upstream release
404
405 * Fri Aug 3 2012 Steven Dake <sdake@redhat.com> - 2.0.1-3
406 - add groff as a BuildRequires as it is no longer installed in the buildroot
407
408 * Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.1-2
409 - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
410
411 * Tue May 22 2012 Jan Friesse <jfriesse@redhat.com> - 2.0.1-1
412 - New upstream release
413
414 * Tue Apr 17 2012 Fabio M. Di Nitto <fdinitto@redhat.com> - 2.0.0-2
415 - Backport IPCS fix from master (ack by Steven)
416
417 * Tue Apr 10 2012 Jan Friesse <jfriesse@redhat.com> - 2.0.0-1
418 - New upstream release
419
420 * Thu Apr 05 2012 Karsten Hopp <karsten@redhat.com> 1.99.9-1.1
421 - bump release and rebuild on PPC
422
423 * Tue Mar 27 2012 Jan Friesse <jfriesse@redhat.com> - 1.99.9-1
424 - New upstream release
425
426 * Fri Mar 16 2012 Jan Friesse <jfriesse@redhat.com> - 1.99.8-1
427 - New upstream release
428
429 * Tue Mar  6 2012 Jan Friesse <jfriesse@redhat.com> - 1.99.7-1
430 - New upstream release
431
432 * Tue Feb 28 2012 Jan Friesse <jfriesse@redhat.com> - 1.99.6-1
433 - New upstream release
434
435 * Wed Feb 22 2012 Jan Friesse <jfriesse@redhat.com> - 1.99.5-1
436 - New upstream release
437
438 * Tue Feb 14 2012 Jan Friesse <jfriesse@redhat.com> - 1.99.4-1
439 - New upstream release
440
441 * Tue Feb 14 2012 Jan Friesse <jfriesse@redhat.com> - 1.99.3-1
442 - New upstream release
443
444 * Tue Feb  7 2012 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.99.2-1
445 - New upstream release
446 - Re-enable xmlconfig bits
447 - Ship cmap man pages
448 - Add workaround to usrmove breakage!!
449
450 * Thu Feb  2 2012 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.99.1-2
451 - Add proper Obsoltes on openais/cman/clusterlib
452
453 * Wed Feb  1 2012 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.99.1-1
454 - New upstream release
455 - Temporary disable xml config (broken upstream tarball)
456
457 * Tue Jan 24 2012 Jan Friesse <jfriesse@redhat.com> - 1.99.0-1
458 - New upstream release
459
460 * Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.2-2
461 - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
462
463 * Thu Oct 06 2011 Jan Friesse <jfriesse@redhat.com> - 1.4.2-1
464 - New upstream release
465
466 * Thu Sep 08 2011 Jan Friesse <jfriesse@redhat.com> - 1.4.1-2
467 - Add upstream fixes
468
469 * Tue Jul 26 2011 Jan Friesse <jfriesse@redhat.com> - 1.4.1-1
470 - New upstream release
471
472 * Wed Jul 20 2011 Jan Friesse <jfriesse@redhat.com> - 1.4.0-2
473 - Change attributes of cluster log directory
474
475 * Tue Jul 19 2011 Jan Friesse <jfriesse@redhat.com> - 1.4.0-1
476 - New upstream release
477 - Resync spec file with upstream changes
478
479 * Fri Jul 08 2011 Jan Friesse <jfriesse@redhat.com> - 1.3.2-1
480 - New upstream release
481
482 * Tue May 10 2011 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.3.1-1
483 - New upstream release
484
485 * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-2
486 - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
487
488 * Thu Dec  2 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.3.0-1
489 - New upstream release
490 - drop upstream patch revision-2770.patch now included in release
491 - update spec file to ship corosync-blackbox
492
493 * Thu Sep  2 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.2.8-1
494 - New upstream release
495
496 * Thu Jul 29 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.2.7-1
497 - New upstream release
498
499 * Fri Jul  9 2010 Dan HorĂ¡k <dan[at]danny.cz> - 1.2.6-2
500 - no InfiniBand stack on s390(x)
501
502 * Mon Jul  5 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.2.6-1
503 - New upstream release
504 - Resync spec file with upstream changes
505
506 * Tue May 25 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.2.3-1
507 - New upstream release
508 - Rediff revision 2770 patch
509
510 * Mon May 17 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.2.2-1
511 - New upstream release
512 - Add upstream trunk revision 2770 to add cpg_model_initialize api.
513 - Fix URL and Source0 entries.
514 - Add workaround to broken 1.2.2 Makefile with make -j.
515
516 * Wed Mar 24 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.2.1-1
517 - New upstream release
518
519 * Tue Dec  8 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.2.0-1
520 - New upstream release
521 - Use global instead of define
522 - Update Source0 url
523 - Use more name macro around
524 - Cleanup install section. Init script is now installed by upstream
525 - Cleanup whitespace
526 - Don't deadlock between package upgrade and corosync condrestart
527 - Ship service.d config directory
528 - Fix Conflicts vs Requires
529 - Ship new sam library and man pages
530
531 * Fri Oct 23 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.1.2-1
532 - New upstream release fixes major regression on specific loads
533
534 * Wed Oct 21 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.1.1-1
535 - New upstream release
536
537 * Fri Sep 25 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.1.0-1
538 - New upstream release
539 - spec file updates:
540   * enable IB support
541   * explicitly define built-in features at configure time
542
543 * Tue Sep 22 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.0.1-1
544 - New upstream release
545 - spec file updates:
546   * use proper configure macro
547
548 * Tue Jul 28 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.0.0-3
549 - spec file updates:
550   * more consistent use of macros across the board
551   * fix directory ownership
552
553 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
554 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
555
556 * Wed Jul  8 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.0.0-1
557 - New upstream release
558
559 * Thu Jul  2 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.100-1
560 - New upstream release
561
562 * Sat Jun 20 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.98-1
563 - New upstream release
564 - spec file updates:
565   * Drop corosync-trunk patch and alpha tag.
566   * Fix alphatag vs buildtrunk handling.
567   * Drop requirement on ais user/group and stop creating them.
568   * New config file locations from upstream: /etc/corosync/corosync.conf.
569
570 * Wed Jun 10 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.97-1.svn2233
571 - spec file updates:
572   * Update to svn version 2233 to include library linking fixes
573
574 * Wed Jun 10 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.97-1.svn2232
575 - New upstream release
576 - spec file updates:
577   * Drop pkgconfig fix that's now upstream
578   * Update to svn version 2232
579   * Define buildtrunk if we are using svn snapshots
580   * BuildRequires: nss-devel to enable nss crypto for network communication
581   * Force autogen invokation if buildtrunk is defined
582   * Whitespace cleanup
583   * Stop shipping corosync.conf in favour of a generic example
584   * Update file list
585
586 * Mon Mar 30 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.95-2
587 - Backport svn commit 1913 to fix pkgconfig files generation
588   and unbreak lvm2 build.
589
590 * Tue Mar 24 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.95-1
591 - New upstream release
592 - spec file updates:
593   * Drop alpha tag
594   * Drop local patches (no longer required)
595   * Allow to build from svn trunk by supporting rpmbuild --with buildtrunk 
596   * BuildRequires autoconf automake if building from trunk
597   * Execute autogen.sh if building from trunk and if no configure is available
598   * Switch to use rpm configure macro and set standard install paths
599   * Build invokation now supports _smp_mflags
600   * Remove install section for docs and use proper doc macro instead
601   * Add tree fixup bits to drop static libs and html docs (only for now)
602   * Add LICENSE file to all subpackages
603   * libraries have moved to libdir. Drop ld.so.conf.d corosync file
604   * Update BuildRoot usage to preferred versions/names
605
606 * Tue Mar 10 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.94-5.svn1797
607 - Update the corosync-trunk patch for real this time.
608
609 * Tue Mar 10 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.94-4.svn1797
610 - Import fixes from upstream:
611   * Cleanup logsys format init around to use default settings (1795)
612   * logsys_format_set should use its own internal copy of format_buffer (1796)
613   * Add logsys_format_get to logsys API (1797)
614 - Cherry pick svn1807 to unbreak CPG.
615
616 * Mon Mar  9 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.94-3.svn1794
617 - Import fixes from upstream:
618   * Add reserve/release feature to totem message queue space (1793)
619   * Fix CG shutdown (1794)
620
621 * Fri Mar  6 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.94-2.svn1792
622 - Import fixes from upstream:
623   * Fix uninitialized memory. Spotted by valgrind (1788)
624   * Fix logsys_set_format by updating the right bits (1789)
625   * logsys: re-add support for timestamp  (1790)
626   * Fix cpg crash (1791)
627   * Allow logsys_format_set to reset to default (1792)
628
629 * Tue Mar  3 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.94-1
630 - New upstream release.
631 - Drop obsolete patches.
632 - Add soname bump patch that was missing from upstream.
633
634 * Wed Feb 25 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.93-4
635 - Add Makefile fix to install all corosync tools (commit r1780)
636
637 * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.93-3
638 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
639
640 * Mon Feb 23 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.93-2
641 - Rename gcc-4.4 patch to match svn commit (r1767).
642 - Backport patch from trunk (commit r1774) to fix quorum engine.
643
644 * Thu Feb 19 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.93-1
645 - New upstream release.
646 - Drop alphatag from spec file.
647 - Drop trunk patch.
648 - Update Provides for corosynclib-devel.
649 - Backport gcc-4.4 build fix from trunk.
650
651 * Mon Feb  2 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.92-7.svn1756
652 - Update to svn trunk at revision 1756 from upstream.
653 - Add support pkgconfig to devel package.
654 - Tidy up spec files by re-organazing sections according to packages.
655 - Split libraries from corosync to corosynclib.
656 - Rename corosync-devel to corosynclib-devel.
657 - Comply with multiarch requirements (libraries).
658
659 * Tue Jan 27 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.92-6.svn1750
660 - Update to svn trunk at revision 1750 from upstream.
661 - Include new quorum service in the packaging.
662
663 * Mon Dec 15 2008 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.92-5.svn1709
664 - Update to svn trunk at revision 1709 from upstream.
665 - Update spec file to include new include files.
666
667 * Wed Dec 10 2008 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.92-4.svn1707
668 - Update to svn trunk at revision 1707 from upstream.
669 - Update spec file to include new lcrso services and include file.
670
671 * Mon Oct 13 2008 Dennis Gilmore <dennis@ausil.us> - 0.92-3
672 - remove ExclusiveArch line
673
674 * Wed Sep 24 2008 Steven Dake <sdake@redhat.com> - 0.92-2
675 - Add conflicts for openais and openais-devel packages older then 0.90.
676
677 * Wed Sep 24 2008 Steven Dake <sdake@redhat.com> - 0.92-1
678 - New upstream release corosync-0.92.
679
680 * Sun Aug 24 2008 Steven Dake <sdake@redhat.com> - 0.91-3
681 - move logsys_overview.8.* to devel package.
682 - move shared libs to main package.
683
684 * Wed Aug 20 2008 Steven Dake <sdake@redhat.com> - 0.91-2
685 - use /sbin/service instead of calling init script directly.
686 - put corosync-objctl man page in the main package.
687 - change all initrddir to initddir for fedora 10 guidelines.
688
689 * Thu Aug 14 2008 Steven Dake <sdake@redhat.com> - 0.91-1
690 - First upstream packaged version of corosync for rawhide review.