Fix building rules for Neutron
[openstack-build/neutron-build.git] / trusty / debian / rules
index 1bb4557a8156f0e7182420e028cc41d363655548..748eaad56f19aeb7dadeee14f866506128ea2d19 100755 (executable)
@@ -16,16 +16,14 @@ override_dh_installinit:
 override_dh_auto_clean:
        dh_clean
 
-get-orig-source:
-       uscan --verbose --force-download --rename --destdir=../build-area
-
-ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
 override_dh_auto_test:
-       # Unpatch quantum configuration to fixup tests which conflict
-       # with a core_plugin being set.
-       patch -p1 -R < debian/patches/fix-neutron-configuration.patch
-       # Set a reasonable level of concurrency
-       ./run_tests.sh -N -P --concurrency=4
-       # Patch configuration file after testing
-       patch -p1 < debian/patches/fix-neutron-configuration.patch
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+       # Unpatch quantum configuration to fixup tests which conflict
+       # with a core_plugin being set.
+       patch -p1 -R < debian/patches/fix-neutron-configuration.patch
+       # Set a reasonable level of concurrency
+       ./run_tests.sh -N -P --concurrency=4
+       # Patch configuration file after testing
+       patch -p1 < debian/patches/fix-neutron-configuration.patch
 endif
+