Deleted backported patch 0007 from spec for RPM.
[openstack-build/neutron-build.git] / rpm / SPECS / openstack-neutron.spec
index 7ef4344e1d618d95c0ad8a7c3582658c0f300c2e..f0d3f1f9cf3d83e3d9f008704c855a56c84c2073 100644 (file)
@@ -1,11 +1,8 @@
-#
-# This is 2013.2 release
-#
-%global release_name havana
+%global release_name icehouse
 
 Name:          openstack-neutron
-Version:       2013.2
-Release:       11%{?dist}
+Version:       2014.1.1
+Release:       1%{?dist}
 Provides:      openstack-quantum = %{version}-%{release}
 Obsoletes:     openstack-quantum < 2013.2-0.3.b3
 
@@ -18,10 +15,6 @@ URL:         http://launchpad.net/neutron/
 Source0:       http://launchpad.net/neutron/%{release_name}/%{version}/+download/neutron-%{version}.tar.gz
 Source1:       neutron.logrotate
 Source2:       neutron-sudoers
-Source4:       neutron-server-setup
-Source5:       neutron-node-setup
-Source6:       neutron-dhcp-setup
-Source7:       neutron-l3-setup
 
 Source10:      neutron-server.init
 Source20:      neutron-server.upstart
@@ -52,9 +45,14 @@ Source42:    neutron-metering-agent.upstart
 
 Source90:      neutron-dist.conf
 #
-# patches_base=2013.2+1
+# patches_base=2014.1.1+1
 #
 Patch0001: 0001-use-parallel-installed-versions-in-RHEL6.patch
+Patch0002: 0002-Remove-dnsmasq-version-warning.patch
+Patch0003: 0003-remove-runtime-dependency-on-pbr.patch
+Patch0004: 0004-Sync-service-and-systemd-modules-from-oslo-incubator.patch
+Patch0005: 0005-Removed-signing_dir-from-neutron.conf.patch
+Patch0006: 0006-Remove-kernel-version-check-for-OVS-VXLAN.patch
 
 BuildArch:     noarch
 
@@ -72,12 +70,10 @@ BuildRequires:      dos2unix
 BuildRequires: python-pbr
 BuildRequires: python-d2to1
 
-
 Requires:      dnsmasq-utils
 Requires:      python-neutron = %{version}-%{release}
+Requires:      python-oslo-rootwrap
 Requires:      openstack-utils
-Requires:      python-keystone
-Requires:      python-pbr
 
 Requires(post):                chkconfig
 Requires(postun):      initscripts
@@ -114,20 +110,25 @@ Requires: python-anyjson
 Requires:      python-babel
 Requires:      python-eventlet
 Requires:      python-greenlet
-Requires:      python-httplib2
+Requires:      python-httplib2 >= 0.7.5
 Requires:      python-iso8601
 Requires:      python-jinja2-26
-Requires:      python-keystoneclient
+Requires:      python-keystoneclient >= 0.7.0
 Requires:      python-kombu
 Requires:      python-lxml
+Requires:      python-oslo-rootwrap
 Requires:      python-paste-deploy1.5
 Requires:      python-routes1.12
-Requires:      python-sqlalchemy0.7
-Requires:      python-webob1.2
+Requires:      python-sqlalchemy0.7 >= 0.7.8
+Requires:      python-webob1.2 >= 1.2.3
 Requires:      python-netaddr
 Requires:      python-oslo-config >= 1:1.2.0
 Requires:      python-qpid
-Requires:      python-neutronclient
+Requires:      python-neutronclient >= 2.3.4
+Requires:      python-stevedore
+Requires:      python-six >= 1.4.1
+# requires.txt six >=1.5.2 actually
+Requires:      python-novaclient >= 1:2.17.0
 Requires:      sudo
 
 %description -n python-neutron
@@ -137,7 +138,7 @@ networks.
 This package contains the neutron Python library.
 
 
-%package -n openstack-neutron-bigswitch
+%package bigswitch
 Summary:       Neutron Big Switch plugin
 Group:         Applications/System
 
@@ -147,7 +148,7 @@ Obsoletes:  openstack-quantum-bigswitch < 2013.2-0.3.b3
 Requires:      openstack-neutron = %{version}-%{release}
 
 
-%description -n openstack-neutron-bigswitch
+%description bigswitch
 Neutron provides an API to dynamically request and configure virtual
 networks.
 
@@ -156,7 +157,7 @@ networks using the FloodLight Openflow Controller or the Big Switch
 Networks Controller.
 
 
-%package -n openstack-neutron-brocade
+%package brocade
 Summary:       Neutron Brocade plugin
 Group:         Applications/System
 
@@ -166,7 +167,7 @@ Obsoletes:  openstack-quantum-brocade < 2013.2-0.3.b3
 Requires:      openstack-neutron = %{version}-%{release}
 
 
-%description -n openstack-neutron-brocade
+%description brocade
 Neutron provides an API to dynamically request and configure virtual
 networks.
 
@@ -174,7 +175,7 @@ This package contains the neutron plugin that implements virtual
 networks using Brocade VCS switches running NOS.
 
 
-%package -n openstack-neutron-cisco
+%package cisco
 Summary:       Neutron Cisco plugin
 Group:         Applications/System
 
@@ -185,7 +186,7 @@ Requires:   openstack-neutron = %{version}-%{release}
 Requires:      python-configobj
 
 
-%description -n openstack-neutron-cisco
+%description cisco
 Neutron provides an API to dynamically request and configure virtual
 networks.
 
@@ -193,7 +194,7 @@ This package contains the neutron plugin that implements virtual
 networks using Cisco UCS and Nexus.
 
 
-%package -n openstack-neutron-hyperv
+%package hyperv
 Summary:       Neutron Hyper-V plugin
 Group:         Applications/System
 
@@ -203,7 +204,7 @@ Obsoletes:  openstack-quantum-hyperv < 2013.2-0.3.b3
 Requires:      openstack-neutron = %{version}-%{release}
 
 
-%description -n openstack-neutron-hyperv
+%description hyperv
 Neutron provides an API to dynamically request and configure virtual
 networks.
 
@@ -211,7 +212,22 @@ This package contains the neutron plugin that implements virtual
 networks using Microsoft Hyper-V.
 
 
-%package -n openstack-neutron-linuxbridge
+%package ibm
+Summary:       Neutron IBM plugin
+Group:         Applications/System
+
+Requires:      openstack-neutron = %{version}-%{release}
+
+
+%description ibm
+Neutron provides an API to dynamically request and configure virtual
+networks.
+
+This package contains the neutron plugin that implements virtual
+networks from IBM.
+
+
+%package linuxbridge
 Summary:       Neutron linuxbridge plugin
 Group:         Applications/System
 
@@ -220,10 +236,9 @@ Obsoletes: openstack-quantum-linuxbridge < 2013.2-0.3.b3
 
 Requires:      bridge-utils
 Requires:      openstack-neutron = %{version}-%{release}
-Requires:      python-pyudev
 
 
-%description -n openstack-neutron-linuxbridge
+%description linuxbridge
 Neutron provides an API to dynamically request and configure virtual
 networks.
 
@@ -231,7 +246,7 @@ This package contains the neutron plugin that implements virtual
 networks as VLANs using Linux bridging.
 
 
-%package -n openstack-neutron-midonet
+%package midonet
 Summary:       Neutron MidoNet plugin
 Group:         Applications/System
 
@@ -241,7 +256,7 @@ Obsoletes:  openstack-quantum-midonet < 2013.2-0.3.b3
 Requires:      openstack-neutron = %{version}-%{release}
 
 
-%description -n openstack-neutron-midonet
+%description midonet
 Neutron provides an API to dynamically request and configure virtual
 networks.
 
@@ -249,7 +264,7 @@ This package contains the neutron plugin that implements virtual
 networks using MidoNet from Midokura.
 
 
-%package -n openstack-neutron-ml2
+%package ml2
 Summary:       Neutron ML2 plugin
 Group:         Applications/System
 
@@ -259,7 +274,7 @@ Obsoletes:  openstack-quantum-ml2 < 2013.2-0.3.b3
 Requires:      openstack-neutron = %{version}-%{release}
 
 
-%description -n openstack-neutron-ml2
+%description ml2
 Neutron provides an API to dynamically request and configure virtual
 networks.
 
@@ -268,7 +283,7 @@ to support separately extensible sets of network types and the mechanisms
 for accessing those types.
 
 
-%package -n openstack-neutron-mellanox
+%package mellanox
 Summary:       Neutron Mellanox plugin
 Group:         Applications/System
 
@@ -278,30 +293,50 @@ Obsoletes:        openstack-quantum-mellanox < 2013.2-0.3.b3
 Requires:      openstack-neutron = %{version}-%{release}
 
 
-%description -n openstack-neutron-mellanox
+%description mellanox
 This plugin implements Neutron v2 APIs with support for Mellanox embedded
 switch functionality as part of the VPI (Ethernet/InfiniBand) HCA.
 
 
-%package -n openstack-neutron-nicira
-Summary:       Neutron Nicira plugin
-Group:         Applications/System
+%package nuage
+Summary:    Neutron Nuage plugin
+Group:      Applications/System
+
+Requires:   openstack-neutron = %{version}-%{release}
+
+
+%description nuage
+This plugin implements Neutron v2 APIs with support for Nuage Networks
+Virtual Service Platform (VSP).
 
-Provides:      openstack-quantum-nicira = %{version}-%{release}
-Obsoletes:     openstack-quantum-nicira < 2013.2-0.3.b3
+
+%package ofagent
+Summary:       Neutron ofagent plugin from ryu project
+Group:         Applications/system
 
 Requires:      openstack-neutron = %{version}-%{release}
 
+%description ofagent
+This plugin implements Neutron v2 APIs with support for the ryu ofagent
+plugin.
 
-%description -n openstack-neutron-nicira
-Neutron provides an API to dynamically request and configure virtual
+
+%package oneconvergence-nvsd
+Summary:       Neutron One Convergence NVSD plugin
+Group:         Applications/System
+
+Requires:      openstack-neutron = %{version}-%{release}
+
+
+%description oneconvergence-nvsd
+Neutron provides an API to dynamnically request and configure virtual
 networks.
 
 This package contains the neutron plugin that implements virtual
-networks using Nicira NVP.
+networks using One Convergence NVSD
 
 
-%package -n openstack-neutron-openvswitch
+%package openvswitch
 Summary:       Neutron openvswitch plugin
 Group:         Applications/System
 
@@ -312,7 +347,7 @@ Requires:   openstack-neutron = %{version}-%{release}
 Requires:      openvswitch
 
 
-%description -n openstack-neutron-openvswitch
+%description openvswitch
 Neutron provides an API to dynamically request and configure virtual
 networks.
 
@@ -320,7 +355,7 @@ This package contains the neutron plugin that implements virtual
 networks using Open vSwitch.
 
 
-%package -n openstack-neutron-plumgrid
+%package plumgrid
 Summary:       Neutron PLUMgrid plugin
 Group:         Applications/System
 
@@ -330,7 +365,7 @@ Obsoletes:  openstack-quantum-plumgrid < 2013.2-0.3.b3
 Requires:      openstack-neutron = %{version}-%{release}
 
 
-%description -n openstack-neutron-plumgrid
+%description plumgrid
 Neutron provides an API to dynamically request and configure virtual
 networks.
 
@@ -338,7 +373,7 @@ This package contains the neutron plugin that implements virtual
 networks using the PLUMgrid platform.
 
 
-%package -n openstack-neutron-ryu
+%package ryu
 Summary:       Neutron Ryu plugin
 Group:         Applications/System
 
@@ -348,7 +383,7 @@ Obsoletes:  openstack-quantum-ryu < 2013.2-0.3.b3
 Requires:      openstack-neutron = %{version}-%{release}
 
 
-%description -n openstack-neutron-ryu
+%description ryu
 Neutron provides an API to dynamically request and configure virtual
 networks.
 
@@ -356,7 +391,7 @@ This package contains the neutron plugin that implements virtual
 networks using the Ryu Network Operating System.
 
 
-%package -n openstack-neutron-nec
+%package nec
 Summary:       Neutron NEC plugin
 Group:         Applications/System
 
@@ -366,7 +401,7 @@ Obsoletes:  openstack-quantum-nec < 2013.2-0.3.b3
 Requires:      openstack-neutron = %{version}-%{release}
 
 
-%description -n openstack-neutron-nec
+%description nec
 Neutron provides an API to dynamically request and configure virtual
 networks.
 
@@ -374,7 +409,7 @@ This package contains the neutron plugin that implements virtual
 networks using the NEC OpenFlow controller.
 
 
-%package -n openstack-neutron-metaplugin
+%package metaplugin
 Summary:       Neutron meta plugin
 Group:         Applications/System
 
@@ -384,7 +419,7 @@ Obsoletes:  openstack-quantum-metaplugin < 2013.2-0.3.b3
 Requires:      openstack-neutron = %{version}-%{release}
 
 
-%description -n openstack-neutron-metaplugin
+%description metaplugin
 Neutron provides an API to dynamically request and configure virtual
 networks.
 
@@ -392,25 +427,38 @@ This package contains the neutron plugin that implements virtual
 networks using multiple other neutron plugins.
 
 
-%package -n openstack-neutron-metering-agent
+%package vmware
+Summary:       Neutron VMWare NSX support
+Group:         Applications/System
+
+Requires:      openstack-neutron = %{version}-%{release}
+Provides:      openstack-neutron-nicira = %{version}-%{release}
+Obsoletes:     openstack-neutron-nicira < 2014.1-4
+
+%description vmware
+This package adds VMWare NSX support for neutron
+
+
+%package metering-agent
 Summary:       Neutron bandwidth metering agent
 Group:         Applications/System
 
 Requires:      openstack-neutron = %{version}-%{release}
 
-%description -n openstack-neutron-metering-agent
+%description metering-agent
 Neutron provides an API to measure bandwidth utilization
 
 This package contains the neutron agent responsible for generating bandwidth
 utilization notifications.
 
-%package -n openstack-neutron-vpn-agent
+
+%package vpn-agent
 Summary:       Neutron VPNaaS agent
 Group:         Applications/System
 
 Requires:      openstack-neutron = %{version}-%{release}
 
-%description -n openstack-neutron-vpn-agent
+%description vpn-agent
 Neutron provides an API to implement VPN as a service
 
 This package contains the neutron agent responsible for implenting VPNaaS with
@@ -421,9 +469,22 @@ IPSec.
 %setup -q -n neutron-%{version}
 
 %patch0001 -p1
+%patch0002 -p1
+%patch0003 -p1
+%patch0004 -p1
+%patch0005 -p1
+%patch0006 -p1
 
 find neutron -name \*.py -exec sed -i '/\/usr\/bin\/env python/{d;q}' {} +
 
+# Ensure SOURCES.txt ends in a newline and if any patches have added files, append them to SOURCES.txt
+[ -n "$(tail -c 1 < neutron.egg-info/SOURCES.txt)" ] && echo >> neutron.egg-info/SOURCES.txt
+if ls %{_sourcedir}/*.patch >/dev/null 2>&1; then
+awk '/^new file/ {split(a,files," ");print substr(files[3],3)} {a = $0}' %{_sourcedir}/*.patch >> neutron.egg-info/SOURCES.txt
+fi
+
+sed -i 's/RPMVERSION/%{version}/; s/RPMRELEASE/%{release}/' neutron/version.py
+
 chmod 644 neutron/plugins/cisco/README
 
 # Let's handle dependencies ourseleves
@@ -467,8 +528,12 @@ mv %{buildroot}/usr/etc/neutron/rootwrap.d/*.filters %{buildroot}%{_datarootdir}
 # Move config files to proper location
 install -d -m 755 %{buildroot}%{_sysconfdir}/neutron
 mv %{buildroot}/usr/etc/neutron/* %{buildroot}%{_sysconfdir}/neutron
+mv %{buildroot}%{_sysconfdir}/neutron/api-paste.ini %{buildroot}%{_datadir}/neutron/api-paste.ini
 chmod 640  %{buildroot}%{_sysconfdir}/neutron/plugins/*/*.ini
 
+# TODO: remove this once the plugin is separately packaged
+rm %{buildroot}%{_sysconfdir}/neutron/plugins/embrane/heleos_conf.ini
+
 # Install logrotate
 install -p -D -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/logrotate.d/openstack-neutron
 
@@ -496,12 +561,6 @@ install -d -m 755 %{buildroot}%{_sharedstatedir}/neutron
 install -d -m 755 %{buildroot}%{_localstatedir}/log/neutron
 install -d -m 755 %{buildroot}%{_localstatedir}/run/neutron
 
-# Install setup helper scripts
-install -p -D -m 755 %{SOURCE4} %{buildroot}%{_bindir}/neutron-server-setup
-install -p -D -m 755 %{SOURCE5} %{buildroot}%{_bindir}/neutron-node-setup
-install -p -D -m 755 %{SOURCE6} %{buildroot}%{_bindir}/neutron-dhcp-setup
-install -p -D -m 755 %{SOURCE7} %{buildroot}%{_bindir}/neutron-l3-setup
-
 # Install upstart jobs examples
 install -p -m 644 %{SOURCE20} %{buildroot}%{_datadir}/neutron/
 install -p -m 644 %{SOURCE21} %{buildroot}%{_datadir}/neutron/
@@ -575,6 +634,7 @@ if rpm --quiet -q openstack-quantum; then
       sed -re 's/[0-6]:off//g
                s/([0-6]):on\s*/\1/g
                s/quantum/neutron/g
+               s/^([a-z0-9-]+)\s+$/chkconfig \1 off/
                s/^([a-z0-9-]+)\s+([0-6]+)/chkconfig --levels \2 \1 on/' > %{_localstatedir}/lib/rpm-state/UPGRADE_FROM_QUANTUM
 fi
 
@@ -607,73 +667,73 @@ if [ -e %{_localstatedir}/lib/rpm-state/UPGRADE_FROM_QUANTUM ];then
 fi
 
 
-%post -n openstack-neutron-linuxbridge
+%post linuxbridge
 if [ $1 -eq 1 ] ; then
     # Initial installation
     /sbin/chkconfig --add neutron-linuxbridge-agent
 fi
 
-%preun -n openstack-neutron-linuxbridge
+%preun linuxbridge
 if [ $1 -eq 0 ] ; then
     # Package removal, not upgrade
     /sbin/service neutron-linuxbridge-agent stop >/dev/null 2>&1
     /sbin/chkconfig --del neutron-linuxbridge-agent
 fi
 
-%postun -n openstack-neutron-linuxbridge
+%postun linuxbridge
 if [ $1 -ge 1 ] ; then
     # Package upgrade, not uninstall
     /sbin/service neutron-linuxbridge-agent condrestart >/dev/null 2>&1 || :
 fi
 
 
-%post -n openstack-neutron-openvswitch
+%post openvswitch
 if [ $1 -eq 1 ] ; then
     # Initial installation
     /sbin/chkconfig --add neutron-openvswitch-agent
 fi
 
-%preun -n openstack-neutron-openvswitch
+%preun openvswitch
 if [ $1 -eq 0 ] ; then
     # Package removal, not upgrade
     /sbin/service neutron-openvswitch-agent stop >/dev/null 2>&1
     /sbin/chkconfig --del neutron-openvswitch-agent
 fi
 
-%postun -n openstack-neutron-openvswitch
+%postun openvswitch
 if [ $1 -ge 1 ] ; then
     # Package upgrade, not uninstall
     /sbin/service neutron-openvswitch-agent condrestart >/dev/null 2>&1 || :
 fi
 
 
-%post -n openstack-neutron-ryu
+%post ryu
 if [ $1 -eq 1 ] ; then
     # Initial installation
     /sbin/chkconfig --add neutron-ryu-agent
 fi
 
-%preun -n openstack-neutron-ryu
+%preun ryu
 if [ $1 -eq 0 ] ; then
     # Package removal, not upgrade
     /sbin/service neutron-ryu-agent stop >/dev/null 2>&1
     /sbin/chkconfig --del neutron-ryu-agent
 fi
 
-%postun -n openstack-neutron-ryu
+%postun ryu
 if [ $1 -ge 1 ] ; then
     # Package upgrade, not uninstall
     /sbin/service neutron-ryu-agent condrestart >/dev/null 2>&1 || :
 fi
 
 
-%post -n openstack-neutron-nec
+%post nec
 if [ $1 -eq 1 ] ; then
     # Initial installation
     /sbin/chkconfig --add neutron-nec-agent
 fi
 
-%preun -n openstack-neutron-nec
+%preun nec
 if [ $1 -eq 0 ] ; then
     # Package removal, not upgrade
     /sbin/service neutron-nec-agent stop >/dev/null 2>&1
@@ -681,7 +741,7 @@ if [ $1 -eq 0 ] ; then
 fi
 
 
-%postun -n openstack-neutron-nec
+%postun nec
 /bin/systemctl daemon-reload >/dev/null 2>&1 || :
 if [ $1 -ge 1 ] ; then
     # Package upgrade, not uninstall
@@ -689,60 +749,60 @@ if [ $1 -ge 1 ] ; then
 fi
 
 
-%post -n openstack-neutron-mellanox
+%post mellanox
 if [ $1 -eq 1 ] ; then
     # Initial installation
     /sbin/chkconfig --add neutron-mlnx-agent
 fi
 
-%preun -n openstack-neutron-mellanox
+%preun mellanox
 if [ $1 -eq 0 ] ; then
     # Package removal, not upgrade
     /sbin/service neutron-mlnx-agent stop >/dev/null 2>&1
     /sbin/chkconfig --del neutron-mlnx-agent
 fi
 
-%postun -n openstack-neutron-mellanox
+%postun mellanox
 if [ $1 -ge 1 ] ; then
     # Package upgrade, not uninstall
     /sbin/service neutron-mlnx-agent condrestart >/dev/null 2>&1 || :
 fi
 
 
-%post -n openstack-neutron-vpn-agent
+%post vpn-agent
 if [ $1 -eq 1 ] ; then
     # Initial installation
     /sbin/chkconfig --add neutron-vpn-agent
 fi
 
-%preun -n openstack-neutron-vpn-agent
+%preun vpn-agent
 if [ $1 -eq 0 ] ; then
     # Package removal, not upgrade
     /sbin/service neutron-vpn-agent stop >/dev/null 2>&1
     /sbin/chkconfig --del neutron-vpn-agent
 fi
 
-%postun -n openstack-neutron-vpn-agent
+%postun vpn-agent
 if [ $1 -ge 1 ] ; then
     # Package upgrade, not uninstall
     /sbin/service neutron-vpn-agent condrestart >/dev/null 2>&1 || :
 fi
 
 
-%post -n openstack-neutron-metering-agent
+%post metering-agent
 if [ $1 -eq 1 ] ; then
     # Initial installation
     /sbin/chkconfig --add neutron-metering-agent
 fi
 
-%preun -n openstack-neutron-metering-agent
+%preun metering-agent
 if [ $1 -eq 0 ] ; then
     # Package removal, not upgrade
     /sbin/service neutron-metering-agent stop >/dev/null 2>&1
     /sbin/chkconfig --del neutron-metering-agent
 fi
 
-%postun -n openstack-neutron-metering-agent
+%postun metering-agent
 if [ $1 -ge 1 ] ; then
     # Package upgrade, not uninstall
     /sbin/service neutron-metering-agent condrestart >/dev/null 2>&1 || :
@@ -767,18 +827,14 @@ fi
 %{_bindir}/neutron-db-manage
 %{_bindir}/neutron-debug
 %{_bindir}/neutron-dhcp-agent
-%{_bindir}/neutron-dhcp-setup
 %{_bindir}/neutron-l3-agent
-%{_bindir}/neutron-l3-setup
 %{_bindir}/neutron-lbaas-agent
 %{_bindir}/neutron-metadata-agent
 %{_bindir}/neutron-netns-cleanup
-%{_bindir}/neutron-node-setup
 %{_bindir}/neutron-ns-metadata-proxy
 %{_bindir}/neutron-rootwrap
 %{_bindir}/neutron-rootwrap-xen-dom0
 %{_bindir}/neutron-server
-%{_bindir}/neutron-server-setup
 %{_bindir}/neutron-usage-audit
 
 %{_initrddir}/neutron-server
@@ -796,8 +852,9 @@ fi
 %dir %{_sysconfdir}/neutron
 %{_sysconfdir}/neutron/release
 %attr(-, root, neutron) %{_datadir}/neutron/neutron-dist.conf
-%config(noreplace) %attr(0640, root, neutron) %{_sysconfdir}/neutron/api-paste.ini
+%attr(-, root, neutron) %{_datadir}/neutron/api-paste.ini
 %config(noreplace) %attr(0640, root, neutron) %{_sysconfdir}/neutron/dhcp_agent.ini
+%config(noreplace) %attr(0640, root, neutron) %{_sysconfdir}/neutron/fwaas_driver.ini
 %config(noreplace) %attr(0640, root, neutron) %{_sysconfdir}/neutron/l3_agent.ini
 %config(noreplace) %attr(0640, root, neutron) %{_sysconfdir}/neutron/metadata_agent.ini
 %config(noreplace) %attr(0640, root, neutron) %{_sysconfdir}/neutron/lbaas_agent.ini
@@ -827,28 +884,35 @@ fi
 %exclude %{python_sitelib}/neutron/plugins/brocade
 %exclude %{python_sitelib}/neutron/plugins/cisco
 %exclude %{python_sitelib}/neutron/plugins/hyperv
+%exclude %{python_sitelib}/neutron/plugins/ibm
 %exclude %{python_sitelib}/neutron/plugins/linuxbridge
 %exclude %{python_sitelib}/neutron/plugins/metaplugin
 %exclude %{python_sitelib}/neutron/plugins/midonet
 %exclude %{python_sitelib}/neutron/plugins/ml2
 %exclude %{python_sitelib}/neutron/plugins/mlnx
+%exclude %{python_sitelib}/neutron/plugins/nuage
 %exclude %{python_sitelib}/neutron/plugins/nec
 %exclude %{python_sitelib}/neutron/plugins/nicira
+%exclude %{python_sitelib}/neutron/plugins/ofagent
+%exclude %{python_sitelib}/neutron/plugins/oneconvergence
 %exclude %{python_sitelib}/neutron/plugins/openvswitch
 %exclude %{python_sitelib}/neutron/plugins/plumgrid
 %exclude %{python_sitelib}/neutron/plugins/ryu
+%exclude %{python_sitelib}/neutron/plugins/vmware
 %{python_sitelib}/neutron-%%{version}*.egg-info
 
 
-%files -n openstack-neutron-bigswitch
+%files bigswitch
 %doc LICENSE
 %doc neutron/plugins/bigswitch/README
+%{_bindir}/neutron-restproxy-agent
 %{python_sitelib}/neutron/plugins/bigswitch
 %dir %{_sysconfdir}/neutron/plugins/bigswitch
 %config(noreplace) %attr(0640, root, neutron) %{_sysconfdir}/neutron/plugins/bigswitch/*.ini
+%doc %{_sysconfdir}/neutron/plugins/bigswitch/README
 
 
-%files -n openstack-neutron-brocade
+%files brocade
 %doc LICENSE
 %doc neutron/plugins/brocade/README.md
 %{python_sitelib}/neutron/plugins/brocade
@@ -856,7 +920,7 @@ fi
 %config(noreplace) %attr(0640, root, neutron) %{_sysconfdir}/neutron/plugins/brocade/*.ini
 
 
-%files -n openstack-neutron-cisco
+%files cisco
 %doc LICENSE
 %doc neutron/plugins/cisco/README
 %{python_sitelib}/neutron/plugins/cisco
@@ -864,7 +928,7 @@ fi
 %config(noreplace) %attr(0640, root, neutron) %{_sysconfdir}/neutron/plugins/cisco/*.ini
 
 
-%files -n openstack-neutron-hyperv
+%files hyperv
 %doc LICENSE
 #%%doc neutron/plugins/hyperv/README
 %{_bindir}/neutron-hyperv-agent
@@ -875,7 +939,17 @@ fi
 %config(noreplace) %attr(0640, root, neutron) %{_sysconfdir}/neutron/plugins/hyperv/*.ini
 
 
-%files -n openstack-neutron-linuxbridge
+%files ibm
+%doc LICENSE
+%{_bindir}/neutron-ibm-agent
+%{_bindir}/quantum-ibm-agent
+%doc neutron/plugins/ibm/README
+%{python_sitelib}/neutron/plugins/ibm
+%dir %{_sysconfdir}/neutron/plugins/ibm
+%config(noreplace) %attr(0640, root, neutron) %{_sysconfdir}/neutron/plugins/ibm/*.ini
+
+
+%files linuxbridge
 %doc LICENSE
 %doc neutron/plugins/linuxbridge/README
 %{_bindir}/neutron-linuxbridge-agent
@@ -888,7 +962,7 @@ fi
 %config(noreplace) %attr(0640, root, neutron) %{_sysconfdir}/neutron/plugins/linuxbridge/*.ini
 
 
-%files -n openstack-neutron-midonet
+%files midonet
 %doc LICENSE
 #%%doc neutron/plugins/midonet/README
 %{python_sitelib}/neutron/plugins/midonet
@@ -896,14 +970,14 @@ fi
 %config(noreplace) %attr(0640, root, neutron) %{_sysconfdir}/neutron/plugins/midonet/*.ini
 
 
-%files -n openstack-neutron-ml2
+%files ml2
 %doc neutron/plugins/ml2/README
 %{python_sitelib}/neutron/plugins/ml2
 %dir %{_sysconfdir}/neutron/plugins/ml2
 %config(noreplace) %attr(0640, root, neutron) %{_sysconfdir}/neutron/plugins/ml2/*.ini
 
 
-%files -n openstack-neutron-mellanox
+%files mellanox
 %doc neutron/plugins/mlnx/README
 %{_bindir}/neutron-mlnx-agent
 %{_bindir}/quantum-mlnx-agent
@@ -913,18 +987,29 @@ fi
 %dir %{_sysconfdir}/neutron/plugins/mlnx
 %config(noreplace) %attr(0640, root, neutron) %{_sysconfdir}/neutron/plugins/mlnx/*.ini
 
+%files nuage
+%doc LICENSE
+%{python_sitelib}/neutron/plugins/nuage
+%dir %{_sysconfdir}/neutron/plugins/nuage
+%config(noreplace) %attr(0640, root, neutron) %{_sysconfdir}/neutron/plugins/nuage/*.ini
+
+%files ofagent
+%doc neutron/plugins/ofagent/README
+%{_bindir}/neutron-ofagent-agent
+%{python_sitelib}/neutron/plugins/ofagent
+
 
-%files -n openstack-neutron-nicira
+%files oneconvergence-nvsd
 %doc LICENSE
-%doc neutron/plugins/nicira/README
-%{_bindir}/neutron-check-nvp-config
-%{_bindir}/quantum-check-nvp-config
-%{python_sitelib}/neutron/plugins/nicira
-%dir %{_sysconfdir}/neutron/plugins/nicira
-%config(noreplace) %attr(0640, root, neutron) %{_sysconfdir}/neutron/plugins/nicira/*.ini
+%doc neutron/plugins/oneconvergence/README
+%dir %{_sysconfdir}/neutron/plugins/oneconvergence
+%config(noreplace) %attr(0640, root, neutron) %{_sysconfdir}/neutron/plugins/oneconvergence/nvsdplugin.ini
+%{_bindir}/neutron-nvsd-agent
+%{_bindir}/quantum-nvsd-agent
+%{python_sitelib}/neutron/plugins/oneconvergence
 
 
-%files -n openstack-neutron-openvswitch
+%files openvswitch
 %doc LICENSE
 %doc neutron/plugins/openvswitch/README
 %{_bindir}/neutron-openvswitch-agent
@@ -941,7 +1026,7 @@ fi
 %config(noreplace) %attr(0640, root, neutron) %{_sysconfdir}/neutron/plugins/openvswitch/*.ini
 
 
-%files -n openstack-neutron-plumgrid
+%files plumgrid
 %doc LICENSE
 %doc neutron/plugins/plumgrid/README
 %{python_sitelib}/neutron/plugins/plumgrid
@@ -949,7 +1034,7 @@ fi
 %config(noreplace) %attr(0640, root, neutron) %{_sysconfdir}/neutron/plugins/plumgrid/*.ini
 
 
-%files -n openstack-neutron-ryu
+%files ryu
 %doc LICENSE
 %doc neutron/plugins/ryu/README
 %{_bindir}/neutron-ryu-agent
@@ -962,7 +1047,7 @@ fi
 %config(noreplace) %attr(0640, root, neutron) %{_sysconfdir}/neutron/plugins/ryu/*.ini
 
 
-%files -n openstack-neutron-nec
+%files nec
 %doc LICENSE
 %doc neutron/plugins/nec/README
 %{_bindir}/neutron-nec-agent
@@ -975,7 +1060,7 @@ fi
 %config(noreplace) %attr(0640, root, neutron) %{_sysconfdir}/neutron/plugins/nec/*.ini
 
 
-%files -n openstack-neutron-metaplugin
+%files metaplugin
 %doc LICENSE
 %doc neutron/plugins/metaplugin/README
 %{python_sitelib}/neutron/plugins/metaplugin
@@ -983,7 +1068,7 @@ fi
 %config(noreplace) %attr(0640, root, neutron) %{_sysconfdir}/neutron/plugins/metaplugin/*.ini
 
 
-%files -n openstack-neutron-metering-agent
+%files metering-agent
 %doc LICENSE
 %config(noreplace) %attr(0640, root, neutron) %{_sysconfdir}/neutron/metering_agent.ini
 %{_initrddir}/neutron-metering-agent
@@ -991,7 +1076,20 @@ fi
 %{_bindir}/neutron-metering-agent
 
 
-%files -n openstack-neutron-vpn-agent
+%files vmware
+%doc LICENSE
+%{_bindir}/neutron-check-nvp-config
+%{_bindir}/quantum-check-nvp-config
+%{_bindir}/neutron-check-nsx-config
+%{_bindir}/neutron-nsx-manage
+%{python_sitelib}/neutron/plugins/vmware
+%dir %{_sysconfdir}/neutron/plugins/vmware
+%dir %{_sysconfdir}/neutron/plugins/nicira
+%config(noreplace) %attr(0640, root, neutron) %{_sysconfdir}/neutron/plugins/vmware/*.ini
+%config(noreplace) %attr(0640, root, neutron) %{_sysconfdir}/neutron/plugins/nicira/*.ini
+
+
+%files vpn-agent
 %doc LICENSE
 %config(noreplace) %attr(0640, root, neutron) %{_sysconfdir}/neutron/vpn_agent.ini
 %{_initrddir}/neutron-vpn-agent
@@ -1001,6 +1099,135 @@ fi
 
 
 %changelog
+* Fri Jun 13 2014 Ihar Hrachyshka <ihrachys@redhat.com> 2014.1.1-1
+- Update to upstream 2014.1.1
+- Added previously missing ml2_conf_mlnx.ini, bz#1100136
+
+* Wed Jun 11 2014 Ihar Hrachyshka <ihrachys@redhat.com> 2014.1-21
+- Ensure routing key is specified in the address for a direct producer, bz#1108025
+
+* Thu May 29 2014 Miguel Ángel Ajo <majopela@redhat.com> 2014.1-20
+- Add nuage plugin packaging as openstack-neutron-nuage
+
+* Wed May 28 2014 Miguel Angel Ajo <majopela@redhat.com> 2014.1-19
+- Remove kernel version check for OVS VXLAN, not revelant for RDO
+  bz#1081011
+
+* Mon May 19 2014 Ihar Hrachyshka <ihrachys@redhat.com> 2014.1-18
+- netaddr<=0.7.10 raises ValueError instead of AddrFormatError, bz#1090137
+
+* Mon May 19 2014 Ihar Hrachyshka <ihrachys@redhat.com> 2014.1-17
+- Validate CIDR given as ip-prefix in security-group-rule-create, bz#1090137
+
+* Fri May 16 2014 Ihar Hrachyshka <ihrachys@redhat.com> 2014.1-16
+- Fixed neutron-server startup due to duplicate options
+
+* Thu May 15 2014 Ihar Hrachyshka <ihrachys@redhat.com> 2014.1-15
+- Make neutron-vpn-agent read fwaas_driver.ini, bz#1098121
+
+* Tue Apr 29 2014 Ihar Hrachyshka <ihrachys@redhat.com> 2014.1-14
+- Removed signing_dir from neutron-dist.conf, again (bz#1050842)
+
+* Wed Apr 23 2014 Ihar Hrachyshka <ihrachys@redhat.com> 2014.1-13
+- Removed obsolete setup scripts
+
+* Wed Apr 23 2014 Ihar Hrachyshka <ihrachys@redhat.com> 2014.1-12
+- Removed signing_dir from neutron.conf
+
+* Tue Apr 22 2014 Ihar Hrachyshka <ihrachys@redhat.com> 2014.1-11
+- Pin python-novaclient dependency to >= 2.17.0
+
+* Fri Apr 18 2014 Pádraig Brady <pbrady@redhat.com> - 2014.1-10
+- Remove uneeded dep on python-keystone
+
+* Fri Apr 18 2014 Ihar Hrachyshka <ihrachys@redhat.com> 2014.1-7
+- Require python-novaclient (used for Nova notifications)
+
+* Fri Apr 18 2014 Ihar Hrachyshka <ihrachys@redhat.com> 2014.1-6
+- We no longer specify notification_driver in neutron-dist.conf
+
+* Fri Apr 18 2014 Ihar Hrachyshka <ihrachys@redhat.com> 2014.1-5
+- Move api-paste.ini to /usr to make sure new values are applied on upgrade
+
+* Fri Apr 18 2014 Terry Wilson <twilson@redhat.com> - 2014.1-4
+- Rename nicira plugin to vmware
+
+* Fri Apr 18 2014 Ihar Hrachyshka <ihrachys@redhat.com> 2014.1-3
+- Clean up neutron-dist.conf to reflect identical upstream defaults
+
+* Fri Apr 18 2014 Ihar Hrachyshka <ihrachys@redhat.com> 2014.1-2
+- Set use_stderr = False to avoid duplicate logging for stderr
+
+* Fri Apr 18 2014 Ihar Hrachyshka <ihrachys@redhat.com> 2014.1-1
+- Update to upstream 2014.1
+
+* Tue Apr 15 2014 Miguel Ángel Ajo <majopela@redhat.com> -2014.1-0.19.rc2
+- Include the systemd readiness notification patch
+
+* Tue Apr 15 2014 Pádraig Brady <pbrady@redhat.com> - 2014.1-0.18.rc2
+- Add missing dependency on python-oslo-rootwrap
+
+* Fri Apr 11 2014 Miguel Angel Ajo <mangelajo@redhat.com> 2014.1-0.17.rc2
+- Update to upstream 2014.1.rc2
+
+* Fri Apr 11 2014 Miguel Ángel Ajo <majopela@redhat.com> 2014.1-0.16.rc1
+- Use rabbitmq by default
+
+* Thu Apr 10 2014 Miguel Ángel Ajo <majopela@redhat.com> 2014.1-0.15.rc1
+- Removes the python-pyudev dependency, bz#1053001
+
+* Thu Apr 10 2014 Ihar Hrachyshka <ihrachys@redhat.com> 2014.1-0.14.rc1
+- Remove signing_dir from neutron-dist.conf, bz#1050842
+
+* Fri Apr 04 2014 Pádraig Brady <pbrady@redhat.com> - 2014.1-0.13.rc1
+- Fix startup issue due to invalid group permissions, bz#1080560
+- Remove runtime dependency on python-pbr
+
+* Wed Apr 02 2014 Terry Wilson <twilson@redhat.com> 2014.1-0.9.rc1
+- Update to upstream 2014.1.rc1
+- Remove python-psutil requires
+
+* Wed Mar 19 2014 Miguel Ángel Ajo <majopela@redhat.com> - 2014.1.b3-8
+- Create agents table when ML2 core_plugin is used
+
+* Tue Mar 11 2014 Miguel Ángel Ajo <majopela@redhat.com> - 2014.1.b3-7
+- Fixed a broken dependency/typo lxaml -> lxml
+- Enforcing python-six >= 1.4.1 at least
+
+* Fri Mar 07 2014 Miguel Ángel Ajo <majopela@redhat.com> - 2014.1.b3-6
+- Update to icehouse milestone 3
+- Add neutron-dhcp-agent dependency bz#1019487
+- Remove nicira plugin, renamed vmware-nsx to vmware bz#1058995
+- Add openstack-neutron-ibm plugin
+- Add openstack-neutron-ofagent plugin from ryu project
+
+* Tue Feb 04 2014 Pádraig Brady <pbrady@redhat.com> - 2014.1.b2-5
+- Fix missing dependency on python-stevedore
+
+* Tue Feb 04 2014 Pádraig Brady <pbrady@redhat.com> - 2014.1.b2-4
+- Fix exception on systems with dnsmasq < 2.59
+
+* Mon Jan 27 2014 Terry Wilson <twilson@redhat.com> - 2014.1.b2-3
+- Update to icehouse milestone 2
+
+* Tue Jan 07 2014 Terry Wilson <twilson@redhat.com> - 2014.1.b1-2
+- Add python-psutil requirement for openvswitch agent, bz#1049235
+
+* Mon Dec 23 2013 Pádraig Brady <pbrady@redhat.com> - 2014.1.b1-1
+- Update to icehouse milestone 1
+
+* Wed Dec 18 2013 Pádraig Brady <pbrady@redhat.com> - 2013.2.1-1
+- Update to Havana stable release 2013.2.1
+
+* Fri Dec 13 2013 Terry Wilson <twilson@redhat.com> - 2013.2-13
+- QPID fixes from oslo-incubator, bz#1038711, bz#1038717
+- Remove dnsmasq version warning, bz#997961
+- Ensure that disabled services are properly handled on upgrade, bz#1040704
+
+* Mon Dec 09 2013 Terry Wilson <twilson@redhat.com> - 2013.2-12
+- Add vpnaas/fwaas configs to init scripts, bz#1032450
+- Pass neutron rootwrap.conf in sudoers.d/neutron, bz#984097
+
 * Wed Dec 04 2013 Terry Wilson <twilson@redhat.com> - 2013.2-11
 - Add missing debug and vpnaas rootwrap filters, bz#1034207