Build from master with 2014.2.b2
[openstack-build/neutron-build.git] / debian / rules
index 60e37da0f60cffc12baf1efb7762d5b5708957d4..bfe2012556232bb57294e6fe034fd1560dc467bb 100755 (executable)
@@ -7,7 +7,11 @@
        dh $@  --with python2
 
 override_dh_install:
-       dh_install --fail-missing -X/usr/etc -X/usr/bin/quantum
+       dh_install --fail-missing -X/usr/etc
+
+override_dh_installinit:
+       dh_installinit
+       dh_installinit -pneutron-plugin-openvswitch-agent --no-start --name=neutron-ovs-cleanup
 
 override_dh_auto_clean:
        dh_clean
@@ -19,9 +23,9 @@ ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
 override_dh_auto_test:
        # Unpatch quantum configuration to fixup tests which conflict
        # with a core_plugin being set.
-       patch -p1 -R < debian/patches/fix-quantum-configuration.patch
+       patch -p1 -R < debian/patches/fix-neutron-configuration.patch
        # Set a reasonable level of concurrency
-       ./run_tests.sh -N -P --concurrency=4 || true
+       ./run_tests.sh -N -P --concurrency=4
        # Patch configuration file after testing
-       patch -p1 < debian/patches/fix-quantum-configuration.patch
+       patch -p1 < debian/patches/fix-neutron-configuration.patch
 endif