Update DEB-specs to 2013.2 version
[openstack-build/neutron-build.git] / debian / rules
index 5c69355ab6b6ed59912b4668a060fc4b10c9abe9..60e37da0f60cffc12baf1efb7762d5b5708957d4 100755 (executable)
@@ -17,5 +17,11 @@ get-orig-source:
 
 ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
 override_dh_auto_test:
-       ./run_tests.sh -N -P --concurrency=1 || true
+       # Unpatch quantum configuration to fixup tests which conflict
+       # with a core_plugin being set.
+       patch -p1 -R < debian/patches/fix-quantum-configuration.patch
+       # Set a reasonable level of concurrency
+       ./run_tests.sh -N -P --concurrency=4 || true
+       # Patch configuration file after testing
+       patch -p1 < debian/patches/fix-quantum-configuration.patch
 endif