Update neutron to 9.0.0.0b1
[openstack-build/neutron-build.git] / centos7 / rpm / SPECS / openstack-neutron.spec
index 5c5421c75fc04fab7cea7d006a51be55e88d5ada..756537008e3f2e3f901281045ff98ec526c32621 100644 (file)
@@ -1,7 +1,7 @@
 %global service neutron
 
 Name:           openstack-%{service}
-Version:        8.0.0
+Version:        9.0.0~b1
 Release:        1%{?dist}
 Epoch:          1
 Summary:        OpenStack Networking Service
@@ -39,8 +39,9 @@ BuildRequires:  python2-devel
 BuildRequires:  python-d2to1
 BuildRequires:  python-keystoneauth1 >= 2.1.0
 BuildRequires:  python-keystonemiddleware
-BuildRequires:  python-neutron-lib
+BuildRequires:  python-neutron-lib >= 0.2.0
 BuildRequires:  python-novaclient
+BuildRequires:  python-oslo-cache
 BuildRequires:  python-oslo-concurrency
 BuildRequires:  python-oslo-config
 BuildRequires:  python-oslo-db
@@ -49,7 +50,9 @@ BuildRequires:  python-oslo-messaging
 BuildRequires:  python-oslo-policy
 BuildRequires:  python-oslo-rootwrap
 BuildRequires:  python-oslo-service
-BuildRequires:  python-pbr
+BuildRequires:  python-oslo-versionedobjects
+BuildRequires:  python-osprofiler >= 1.3.0
+BuildRequires:  python-pbr >= 1.6
 BuildRequires:  python-pecan
 BuildRequires:  python-setuptools
 BuildRequires:  systemd-units
@@ -101,8 +104,9 @@ capabilities (e.g., QoS, ACLs, network monitoring, etc.)
 
 %package -n python-%{service}
 Summary:        Neutron Python libraries
-Requires:       python-alembic >= 0.8.0
+Requires:       python-alembic >= 0.8.4
 Requires:       python-debtcollector >= 1.2.0
+Requires:       python-designateclient >= 1.5.0
 Requires:       python-eventlet >= 0.18.2
 Requires:       python-greenlet >= 0.3.2
 Requires:       python-httplib2 >= 0.7.5
@@ -111,32 +115,33 @@ Requires:       python-keystoneauth1 >= 2.1.0
 Requires:       python-keystoneclient >= 1.6.0
 Requires:       python-keystonemiddleware >= 4.0.0
 Requires:       python-netaddr >= 0.7.12
-Requires:       python-neutronclient >= 2.6.0
-Requires:       python-neutron-lib
+Requires:       python-neutronclient >= 4.2.0
+Requires:       python-neutron-lib >= 0.2.0
 Requires:       python-novaclient >= 2.29.0
 Requires:       python-openvswitch
-Requires:       python-oslo-concurrency >= 3.5.0
-Requires:       python-oslo-config >= 2:3.7.0
-Requires:       python-oslo-context >= 0.2.0
+Requires:       python-oslo-cache >= 1.5.0
+Requires:       python-oslo-concurrency >= 3.8.0
+Requires:       python-oslo-config >= 2:3.10.0
+Requires:       python-oslo-context >= 2.4.0
 Requires:       python-oslo-db >= 4.1.0
 Requires:       python-oslo-i18n >= 2.1.0
 Requires:       python-oslo-log >= 1.14.0
-Requires:       python-oslo-messaging >= 4.0.0
+Requires:       python-oslo-messaging >= 5.2.0
 Requires:       python-oslo-middleware >= 3.0.0
-Requires:       python-oslo-policy >= 0.5.0
+Requires:       python-oslo-policy >= 1.9.0
 Requires:       python-oslo-reports >= 0.6.0
 Requires:       python-oslo-rootwrap >= 2.0.0
 Requires:       python-oslo-serialization >= 1.10.0
-Requires:       python-oslo-service >= 1.0.0
-Requires:       python-oslo-utils >= 3.5.0
-Requires:       python-oslo-versionedobjects >= 1.5.0
-Requires:       python-oslo-context >= 0.2.0
+Requires:       python-oslo-service >= 1.10.0
+Requires:       python-oslo-utils >= 3.11.0
+Requires:       python-oslo-versionedobjects >= 1.9.1
+Requires:       python-osprofiler >= 1.3.0
 Requires:       python-paste
 Requires:       python-paste-deploy >= 1.5.0
 Requires:       python-pecan >= 1.0.0
-Requires:       python-pbr
+Requires:       python-pbr >= 1.6
 Requires:       python-pyroute2
-Requires:       python-requests >= 2.8.1
+Requires:       python-requests >= 2.10.0
 Requires:       python-retrying >= 1.2.3
 Requires:       python-routes >= 1.12.3
 Requires:       python-ryu >= 3.30
@@ -158,6 +163,7 @@ This package contains the Neutron Python library.
 %package -n python-%{service}-tests
 Summary:        Neutron tests
 Requires:       python-%{service} = %{epoch}:%{version}-%{release}
+Requires:       python-ddt
 
 
 %description -n python-%{service}-tests
@@ -169,6 +175,7 @@ This package contains Neutron test files.
 
 %package common
 Summary:        Neutron common files
+Requires(pre):  shadow-utils
 Requires:       python-%{service} = %{epoch}:%{version}-%{release}
 Requires:       sudo
 
@@ -180,24 +187,12 @@ networks.
 This package contains Neutron common files.
 
 
-%package bgp-dragent
-Summary:        Neutron BGP Dynamic Routing agent
-Requires:       openstack-%{service}-common = %{epoch}:%{version}-%{release}
-
-
-%description bgp-dragent
-Neutron provides an API to dynamically request and configure virtual
-networks.
-
-This package contains the Neutron BGP Dynamic Routing agent that will host
-different BGP speaking drivers and makes the required BGP peering session/s for
-Neutron.
-
-
 %package linuxbridge
 Summary:        Neutron Linuxbridge agent
 Requires:       bridge-utils
 Requires:       ebtables
+Requires:       ipset
+Requires:       iptables
 Requires:       openstack-%{service}-common = %{epoch}:%{version}-%{release}
 
 
@@ -244,6 +239,8 @@ Requires:       openstack-%{service}-common = %{epoch}:%{version}-%{release}
 # We require openvswitch when using vsctl to access ovsdb;
 # but if we use native access, then we just need python bindings.
 # since we don't know what users actually use, we depend on both.
+Requires:       ipset
+Requires:       iptables
 Requires:       openvswitch
 Requires:       python-openvswitch
 
@@ -258,6 +255,7 @@ networks using Open vSwitch.
 
 %package metering-agent
 Summary:        Neutron bandwidth metering agent
+Requires:       iptables
 Requires:       openstack-%{service}-common = %{epoch}:%{version}-%{release}
 
 
@@ -359,6 +357,8 @@ rm -rf neutron.egg-info
 %build
 export SKIP_PIP_INSTALL=1
 %{__python2} setup.py build
+# Generate i18n files
+%{__python2} setup.py compile_catalog -d build/lib/%{service}/locale
 
 # Generate configuration files
 PYTHONPATH=. tools/generate_config_file_samples.sh
@@ -416,7 +416,6 @@ install -p -D -m 440 %{SOURCE2} %{buildroot}%{_sysconfdir}/sudoers.d/%{service}
 install -p -D -m 644 %{SOURCE10} %{buildroot}%{_unitdir}/neutron-server.service
 install -p -D -m 644 %{SOURCE11} %{buildroot}%{_unitdir}/neutron-linuxbridge-agent.service
 install -p -D -m 644 %{SOURCE12} %{buildroot}%{_unitdir}/neutron-openvswitch-agent.service
-install -p -D -m 644 %{SOURCE13} %{buildroot}%{_unitdir}/neutron-bgp-dragent.service
 install -p -D -m 644 %{SOURCE15} %{buildroot}%{_unitdir}/neutron-dhcp-agent.service
 install -p -D -m 644 %{SOURCE16} %{buildroot}%{_unitdir}/neutron-l3-agent.service
 install -p -D -m 644 %{SOURCE17} %{buildroot}%{_unitdir}/neutron-metadata-agent.service
@@ -451,13 +450,21 @@ mkdir -p %{buildroot}%{_datadir}/%{service}/server
 
 # Create configuration directories for all services that can be populated by users with custom *.conf files
 mkdir -p %{buildroot}/%{_sysconfdir}/%{service}/conf.d/common
-for service in server rpc-server ovs-cleanup netns-cleanup linuxbridge-cleanup bgp-dragent macvtap-agent; do
+for service in server rpc-server ovs-cleanup netns-cleanup linuxbridge-cleanup macvtap-agent; do
     mkdir -p %{buildroot}/%{_sysconfdir}/%{service}/conf.d/%{service}-$service
 done
 for service in linuxbridge openvswitch dhcp l3 metadata metering sriov-nic; do
     mkdir -p %{buildroot}/%{_sysconfdir}/%{service}/conf.d/%{service}-$service-agent
 done
 
+# Install i18n .mo files (.po and .pot are not required)
+install -d -m 755 %{buildroot}%{_datadir}
+rm -f %{buildroot}%{python2_sitelib}/%{service}/locale/*/LC_*/%{service}*po
+rm -f %{buildroot}%{python2_sitelib}/%{service}/locale/*pot
+mv %{buildroot}%{python2_sitelib}/%{service}/locale %{buildroot}%{_datadir}/locale
+
+# Find language files
+%find_lang %{service} --all-name
 
 %pre common
 getent group %{service} >/dev/null || groupadd -r %{service}
@@ -494,18 +501,6 @@ exit 0
 %systemd_postun_with_restart neutron-server.service
 
 
-%post bgp-dragent
-%systemd_post neutron-bgp-dragent.service
-
-
-%preun bgp-dragent
-%systemd_preun neutron-bgp-dragent.service
-
-
-%postun bgp-dragent
-%systemd_postun_with_restart neutron-bgp-dragent.service
-
-
 %post macvtap-agent
 %systemd_post neutron-macvtap-agent.service
 
@@ -639,7 +634,7 @@ fi
 %exclude %{python2_sitelib}/%{service}/tests
 
 
-%files common
+%files common -f %{service}.lang
 %license LICENSE
 %doc README.rst
 %{_bindir}/neutron-rootwrap
@@ -666,13 +661,6 @@ fi
 %{_datarootdir}/%{service}/rootwrap/l3.filters
 
 
-%files bgp-dragent
-%license LICENSE
-%{_bindir}/neutron-bgp-dragent
-%{_unitdir}/neutron-bgp-dragent.service
-%dir %{_sysconfdir}/%{service}/conf.d/%{service}-bgp-dragent
-
-
 %files linuxbridge
 %license LICENSE
 %{_bindir}/neutron-linuxbridge-agent
@@ -738,6 +726,9 @@ fi
 
 
 %changelog
+* Mon Jun 27 2016 Jerzy Mikolajczak <jmikolajczak@mirantis.com> 1:9.0.0.0b1-1.el7
+- Update specs for Newton b1 release
+- Remove neutron-bgp-dragent service
 * Fri Apr 8 2016 Jerzy Mikolajczak <jmikolajczak@mirantis.com> 1:8.0.0-1%{?dist}~mos1
 - Update specs for Mitaka Final release
 * Sun Mar 6 2016 Sergey Kolekonov <skolekonov@mirantis.com> 1:8.0.0.0b3-1.el7