[MOS10.0][DEB] Update ceilometer to v7.0.0
[openstack-build/ceilometer-build.git] / xenial / debian / rules
index 3cf682c01ee2a490888754e4f4e25526ad89bb63..bac62485355116ff45cd0bdad787c2073fb1d8a3 100755 (executable)
@@ -5,7 +5,7 @@ include /usr/share/openstack-pkg-tools/pkgos.make
 export OSLO_PACKAGE_VERSION=$(shell dpkg-parsechangelog | grep Version: | cut -d' ' -f2 | sed -e 's/^[[:digit:]]*://' -e 's/[-].*//' -e 's/~/.0/' | head -n 1)
 
 %:
-       dh $@  --with python2,systemd,sphinxdoc
+       dh $@  --with apache2,python2,systemd,sphinxdoc
 
 override_dh_clean:
        dh_clean
@@ -15,6 +15,8 @@ override_dh_clean:
 override_dh_install:
        rm -rf $(CURDIR)/debian/tmp
        python2.7 setup.py install --install-layout=deb --root $(CURDIR)/debian/tmp
+       rm -rf $(CURDIR)/debian/tmp/usr/etc
+
        dh_install --fail-missing
 
        # Manage ceilometer.conf
@@ -56,7 +58,7 @@ ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
        testr init
        set -e ; \
                TEMP_REZ=`mktemp -t` ; \
-               bash -x ./setup-test-env-mongodb.sh testr run --subunit 'tests\.(?!(.*test_bin.*|.*functional.*|.*gabbi\.test_gabbi_prefix.*))' | tee $$TEMP_REZ | subunit2pyunit ; \
+               bash -x ./debian/setup-test-env-mongodb.sh testr run --subunit --parallel 'tests\.(?!(.*test_bin.*|.*functional.*|.*gabbi\.test_gabbi_prefix.*|.*meter\.test_notifications\.TestMeterProcessing\.test_fallback_meter_path.*|.*agent\.test_manager\.TestRunTasks\.test_batching_polled_samples_false.*))' | tee $$TEMP_REZ | subunit2pyunit ; \
                cat $$TEMP_REZ | subunit-filter -s --no-passthrough | subunit-stats ; \
                rm -f $$TEMP_REZ ;
        testr slowest