Displays unit tests stats correcly.
[openstack-build/ceilometer-build.git] / xenial / debian / rules
index 48e55db96f28d70f1c07c9a37f66d79e8cd42206..a8b2bb685f4b93258fda35006af604a12940fb4e 100755 (executable)
@@ -11,6 +11,7 @@ export OSLO_PACKAGE_VERSION=$(VERSION)
 
 override_dh_clean:
        dh_clean
+       rm -rf .testrepository
        rm -rf ceilometer.egg-info
        rm -f debian/ceilometer-common.config debian/ceilometer-common.postinst debian/ceilometer-api.config debian/ceilometer-api.postinst
 
@@ -34,9 +35,14 @@ override_dh_auto_clean:
        rm -rf debian/ceilometer-common.postinst
        find . -iname '*.pyc' -delete
 
-ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
 override_dh_auto_test:
-       bash -x ./setup-test-env.sh python setup.py testr --slowest '(?!tests.test_bin)' || true
-       #./run-tests.sh || true
-       #PYTHONPATH=. nosetests -P || true
+ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
+       rm -rf .testrepository
+       testr init
+       set -e && \
+               TEMP_REZ=`mktemp -t` && \
+               bash -x ./setup-test-env.sh testr run --subunit 'tests\.(?!.*test_bin.*)' | subunit2pyunit || true ; \
+               cat $$TEMP_REZ | subunit-filter -s --no-passthrough | subunit-stats || true ; \
+               rm -f $$TEMP_REZ ;
+       testr slowest
 endif