Do not run binary command line tests which are failing cause things not installed...
[openstack-build/ceilometer-build.git] / xenial / debian / rules
index 60bf97e9e60a0b753ddeb0716a4781f690057676..48e55db96f28d70f1c07c9a37f66d79e8cd42206 100755 (executable)
@@ -36,7 +36,7 @@ override_dh_auto_clean:
 
 ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
 override_dh_auto_test:
-       bash -x ./setup-test-env.sh python setup.py testr --slowest || true
+       bash -x ./setup-test-env.sh python setup.py testr --slowest '(?!tests.test_bin)' || true
        #./run-tests.sh || true
        #PYTHONPATH=. nosetests -P || true
 endif