Removed debian/rules stuff that is already in pkgos.make
[openstack-build/ceilometer-build.git] / xenial / debian / rules
index 6ea03010c31bc53023872b498deada5be90659eb..1caece13f446753b44550c930fd586681091135f 100755 (executable)
@@ -34,26 +34,3 @@ override_dh_gencontrol:
        else \
                dh_gencontrol -- -T$(CURDIR)/debian/debian_control_vars ; \
        fi
-
-override_dh_builddeb:
-       dh_builddeb -- -Zxz -z9
-
-regen-manifest-patch:
-       quilt pop -a || true
-       quilt push install-missing-files.patch
-       git checkout MANIFEST.in
-       git ls-files --no-empty-directory --exclude-standard nova | grep -v '.py$$' | sed -n 's/.*/include &/gp' >> MANIFEST.in
-       quilt refresh
-       quilt pop -a
-
-get-vcs-source:
-       git remote add upstream git://github.com/openstack/$(DEBPKGNAME).git || true
-       git fetch upstream
-       if [ ! -f ../$(DEBPKGNAME)_$(VERSION).orig.tar.xz ] ; then \
-               git archive --prefix=$(DEBPKGNAME)-$(VERSION)/ $(VERSION) | xz >../$(DEBPKGNAME)_$(VERSION).orig.tar.xz ; \
-       fi
-       if ! git checkout master ; then \
-               echo "No upstream branch: checking out" ; \
-               git checkout -b master upstream/master ; \
-       fi
-       git checkout debian/experimental