]> review.fuel-infra Code Review - openstack-build/ceilometer-build.git/blobdiff - xenial/debian/rules
Now packaging 2013.1~g0+48d8f574e8-1
[openstack-build/ceilometer-build.git] / xenial / debian / rules
index 1caece13f446753b44550c930fd586681091135f..09236a76a5e2eea83b4821554bfaf024e61de052 100755 (executable)
@@ -7,10 +7,9 @@ include /usr/share/openstack-pkg-tools/pkgos.make
 %:
        dh $@  --with python2
 
-DEBVERS := $(shell dpkg-parsechangelog | sed -n -e 's/^Version: //p')
-VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/^[[:digit:]]*://' -e 's/[~-].*//')
-DEBFLAVOR :=$(shell dpkg-parsechangelog | grep -E ^Distribution: | cut -d" " -f2)
-DEBPKGNAME :=$(shell dpkg-parsechangelog | grep -E ^Source: | cut -d" " -f2)
+override_dh_auto_build:
+       dh_auto_build
+       /usr/share/openstack-pkg-tools/pkgos_insert_include pkgos_func ceilometer-common.postinst
 
 override_dh_installchangelogs:
        dh_installchangelogs debian/CHANGELOG
@@ -18,15 +17,7 @@ override_dh_installchangelogs:
 override_dh_auto_clean:
        dh_auto_clean
        rm -rf debian/*.upstart
-
-override_dh_installinit:
-       if dpkg-vendor --derives-from ubuntu ; then \
-               for i in *.upstart.in ; do \
-                       MYPKG=`echo $i | cut -d. -f1` ; \
-                       cp $MYPKG.upstart.in $MYPKG.upstart ; \
-               done ; \
-       fi
-       dh_installinit --error-handler=true
+       rm -rf debian/ceilometer-common.postinst
 
 override_dh_gencontrol:
        if dpkg-vendor --derives-from ubuntu ; then \