Fix double [DEFAULT] within config generation
[openstack-build/cinder-build.git] / trusty / debian / rules
index ec3ee9cba18d5e67f6328561e1a8722eb2d222ff..82fe7bad01468e9262db4c5f1aba273ae0ac6e1f 100755 (executable)
@@ -6,10 +6,7 @@
 include /usr/share/openstack-pkg-tools/pkgos.make
 
 %:
-       dh $@  --with python2,systemd
-
-get-orig-source:
-       uscan --verbose --rename --destdir=../build-area
+       dh $@  --with python2,systemd,sphinxdoc
 
 ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
 override_dh_auto_test:
@@ -23,11 +20,21 @@ endif
 
 override_dh_install:
        dh_install --fail-missing -Xbin/cinder-all
+       install -D -m 0440 debian/cinder_sudoers $(CURDIR)/debian/cinder-common/etc/sudoers.d/cinder-common
+       install -D -m 0644 $(CURDIR)/debian/logging.conf $(CURDIR)/debian/cinder-common/etc/cinder/logging.conf
 
 override_dh_fixperms:
        dh_fixperms -Xcinder_tgt.conf
+       chmod 0440 $(CURDIR)/debian/cinder-common/etc/sudoers.d/cinder-common
 
 override_dh_clean:
        # temporary workaround for d2to1 wonkyness
        dh_clean -Xsetup.cfg
        rm -f debian/*.init debian/*.service debian/*.upstart
+
+override_dh_sphinxdoc:
+ifeq (,$(findstring nodocs, $(DEB_BUILD_OPTIONS)))
+       python setup.py build_sphinx
+       cp -rf doc/build/html $(CURDIR)/debian/cinder-doc/usr/share/doc/cinder-doc
+       dh_sphinxdoc -O--buildsystem=python_distutils
+endif