Add pyroute2 to dependencies for neutron-common
[openstack-build/neutron-build.git] / trusty / debian / rules
index 1bb4557a8156f0e7182420e028cc41d363655548..3712a678badabdc0f9c7667d7eba8a031c00c2a3 100755 (executable)
@@ -4,7 +4,7 @@
 #export DH_VERBOSE=1
 
 %:
-       dh $@  --with python2
+       dh $@  --with python2,sphinxdoc
 
 override_dh_install:
        dh_install --fail-missing -X/usr/etc -X/usr/bin/neutron-hyperv-agent
@@ -16,16 +16,20 @@ override_dh_installinit:
 override_dh_auto_clean:
        dh_clean
 
-get-orig-source:
-       uscan --verbose --force-download --rename --destdir=../build-area
-
-ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
 override_dh_auto_test:
-       # Unpatch quantum configuration to fixup tests which conflict
-       # with a core_plugin being set.
-       patch -p1 -R < debian/patches/fix-neutron-configuration.patch
-       # Set a reasonable level of concurrency
-       ./run_tests.sh -N -P --concurrency=4
-       # Patch configuration file after testing
-       patch -p1 < debian/patches/fix-neutron-configuration.patch
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+       # Unpatch quantum configuration to fixup tests which conflict
+       # with a core_plugin being set.
+       patch -p1 -R < debian/patches/fix-neutron-configuration.patch
+       # Set a reasonable level of concurrency
+       ./run_tests.sh -N -P --concurrency=4
+       # Patch configuration file after testing
+       patch -p1 < debian/patches/fix-neutron-configuration.patch
+endif
+
+override_dh_sphinxdoc:
+ifeq (,$(findstring nodocs, $(DEB_BUILD_OPTIONS)))
+        python setup.py build_sphinx
+        cp -rf doc/build/html $(CURDIR)/debian/neutron-doc/usr/share/doc/neutron-doc
+        dh_sphinxdoc -O--buildsystem=python_distutils
 endif