Add doc package for cinder
[openstack-build/cinder-build.git] / trusty / debian / rules
index ec3ee9cba18d5e67f6328561e1a8722eb2d222ff..2222f4f2b8abc7efd4d9e63d6a6058a2deb55ea7 100755 (executable)
@@ -6,10 +6,7 @@
 include /usr/share/openstack-pkg-tools/pkgos.make
 
 %:
-       dh $@  --with python2,systemd
-
-get-orig-source:
-       uscan --verbose --rename --destdir=../build-area
+       dh $@  --with python2,systemd,sphinxdoc
 
 ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
 override_dh_auto_test:
@@ -31,3 +28,10 @@ override_dh_clean:
        # temporary workaround for d2to1 wonkyness
        dh_clean -Xsetup.cfg
        rm -f debian/*.init debian/*.service debian/*.upstart
+
+override_dh_sphinxdoc:
+ifeq (,$(findstring nodocs, $(DEB_BUILD_OPTIONS)))
+       python setup.py build_sphinx
+       cp -rf doc/build/html $(CURDIR)/debian/cinder-doc/usr/share/doc/cinder-doc
+       dh_sphinxdoc -O--buildsystem=python_distutils
+endif