Removed debian/rules stuff that is already in pkgos.make
[openstack-build/ceilometer-build.git] / trusty / debian / rules
index 16c9d19c92416db072c1ff9afef6c2fadc409a9e..1caece13f446753b44550c930fd586681091135f 100755 (executable)
@@ -2,6 +2,8 @@
 
 #export DH_VERBOSE=1
 
+include /usr/share/openstack-pkg-tools/pkgos.make
+
 %:
        dh $@  --with python2
 
@@ -10,6 +12,9 @@ VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/^[[:digit:]]*://' -e 's/[~-].*/
 DEBFLAVOR :=$(shell dpkg-parsechangelog | grep -E ^Distribution: | cut -d" " -f2)
 DEBPKGNAME :=$(shell dpkg-parsechangelog | grep -E ^Source: | cut -d" " -f2)
 
+override_dh_installchangelogs:
+       dh_installchangelogs debian/CHANGELOG
+
 override_dh_auto_clean:
        dh_auto_clean
        rm -rf debian/*.upstart
@@ -29,26 +34,3 @@ override_dh_gencontrol:
        else \
                dh_gencontrol -- -T$(CURDIR)/debian/debian_control_vars ; \
        fi
-
-override_dh_builddeb:
-       dh_builddeb -- -Zxz -z9
-
-regen-manifest-patch:
-       quilt pop -a || true
-       quilt push install-missing-files.patch
-       git checkout MANIFEST.in
-       git ls-files --no-empty-directory --exclude-standard nova | grep -v '.py$$' | sed -n 's/.*/include &/gp' >> MANIFEST.in
-       quilt refresh
-       quilt pop -a
-
-get-vcs-source:
-       git remote add upstream git://github.com/openstack/$(DEBPKGNAME).git || true
-       git fetch upstream
-       if [ ! -f ../$(DEBPKGNAME)_$(VERSION).orig.tar.xz ] ; then \
-               git archive --prefix=$(DEBPKGNAME)-$(VERSION)/ $(VERSION) | xz >../$(DEBPKGNAME)_$(VERSION).orig.tar.xz ; \
-       fi
-       if ! git checkout master ; then \
-               echo "No upstream branch: checking out" ; \
-               git checkout -b master upstream/master ; \
-       fi
-       git checkout debian/experimental