Add Neutron 2015.1 for Ubuntu 14.04
[openstack-build/neutron-build.git] / trusty / debian / rules
diff --git a/trusty/debian/rules b/trusty/debian/rules
new file mode 100755 (executable)
index 0000000..1bb4557
--- /dev/null
@@ -0,0 +1,31 @@
+#!/usr/bin/make -f
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+%:
+       dh $@  --with python2
+
+override_dh_install:
+       dh_install --fail-missing -X/usr/etc -X/usr/bin/neutron-hyperv-agent
+
+override_dh_installinit:
+       dh_installinit
+       dh_installinit -pneutron-plugin-openvswitch-agent --no-start --name=neutron-ovs-cleanup
+
+override_dh_auto_clean:
+       dh_clean
+
+get-orig-source:
+       uscan --verbose --force-download --rename --destdir=../build-area
+
+ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
+override_dh_auto_test:
+       # Unpatch quantum configuration to fixup tests which conflict
+       # with a core_plugin being set.
+       patch -p1 -R < debian/patches/fix-neutron-configuration.patch
+       # Set a reasonable level of concurrency
+       ./run_tests.sh -N -P --concurrency=4
+       # Patch configuration file after testing
+       patch -p1 < debian/patches/fix-neutron-configuration.patch
+endif