Add cinder 2015.1 for Kilo
[openstack-build/cinder-build.git] / trusty / debian / rules
similarity index 60%
rename from debian/rules
rename to trusty/debian/rules
index f38a7dc148abaeaeae0b954bd162b0d489bb6134..ec3ee9cba18d5e67f6328561e1a8722eb2d222ff 100755 (executable)
@@ -3,15 +3,22 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
+include /usr/share/openstack-pkg-tools/pkgos.make
+
 %:
-       dh $@  --with python2
+       dh $@  --with python2,systemd
 
 get-orig-source:
        uscan --verbose --rename --destdir=../build-area
 
 ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
 override_dh_auto_test:
-       ./run_tests.sh -N -P
+       rm -rf .testrepository
+       testr init && \
+       set -e && \
+       TEMP_REZ=`mktemp -t` && \
+       testr run --subunit | tee $$TEMP_REZ | subunit2pyunit; \
+       rm -f $$TEMP_REZ
 endif
 
 override_dh_install:
@@ -23,3 +30,4 @@ override_dh_fixperms:
 override_dh_clean:
        # temporary workaround for d2to1 wonkyness
        dh_clean -Xsetup.cfg
+       rm -f debian/*.init debian/*.service debian/*.upstart