Add missing python-ceilometer requirements
[openstack-build/ceilometer-build.git] / rpm / SPECS / openstack-ceilometer.spec
index dd3b5f2b2b1695b6c05269b4e7685b60be4294b8..cdee4bdefcf61b38b438ae338941293b3ef2906f 100644 (file)
@@ -3,14 +3,14 @@
 %global pypi_name ceilometer
 
 Name:             openstack-ceilometer
-Version:          2013.2
-Release:          0.8.b3%{?dist}
+Version:          2014.1.1
+Release:          2%{?dist}
 Summary:          OpenStack measurement collection service
 
 Group:            Applications/System
 License:          ASL 2.0
 URL:              https://wiki.openstack.org/wiki/Ceilometer
-Source0:          http://tarballs.openstack.org/%{pypi_name}/%{pypi_name}-%{version}.b3.tar.gz
+Source0:          http://tarballs.openstack.org/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
 Source1:          %{pypi_name}-dist.conf
 Source2:          %{pypi_name}.logrotate
 
@@ -22,11 +22,17 @@ Source12:         %{name}-compute.init
 Source120:        %{name}-compute.upstart
 Source13:         %{name}-central.init
 Source130:        %{name}-central.upstart
+Source14:         %{name}-alarm-notifier.init
+Source140:        %{name}-alarm-notifier.upstart
+Source15:         %{name}-alarm-evaluator.init
+Source150:        %{name}-alarm-evaluator.upstart
+Source16:         %{name}-notification.init
+Source160:        %{name}-notification.upstart
 
 #
-# patches_base=2013.2.b3
+# patches_base=2014.1.1
 #
-Patch0001: 0001-Ensure-we-don-t-access-the-net-when-building-docs.patch
+Patch0001: 0001-Ensure-routing-key-is-specified-in-the-address-for-a.patch
 
 # This is EL6 specific and not upstream
 Patch100:         openstack-ceilometer-newdeps.patch
@@ -57,25 +63,49 @@ Group:            Applications/System
 
 Requires:         python-qpid
 Requires:         python-kombu
-Requires:         python-amqplib
 
+Requires:         python-babel
 Requires:         python-eventlet
 Requires:         python-greenlet
 Requires:         python-iso8601
 Requires:         python-lxml
 Requires:         python-anyjson
-Requires:         python-stevedore
+Requires:         python-jsonpath-rw
+Requires:         python-stevedore >= 0.14
 Requires:         python-msgpack
+Requires:         python-six >= 1.6
+Requires:         PyYAML
+
+Requires:         python-argparse
+Requires:         python-jsonschema
 Requires:         python-netaddr
-Requires:         python-six
+Requires:         python-requests
 
 Requires:         python-sqlalchemy0.7
 Requires:         python-alembic
 Requires:         python-migrate
 
-Requires:         python-webob >= 1.2
-Requires:         python-oslo-config
-Requires:         PyYAML
+Requires:         python-webob >= 1.2.3
+
+Requires:         python-oslo-config >= 1:1.2.0
+
+Requires:         pysnmp
+Requires:         pytz
+Requires:         python-croniter
+
+# These were only added as global dependencies
+# at the end of the Icehouse cycle with the change
+# to cli.py referenced from in http://pad.lv/1317210
+Requires:         python-pymongo
+Requires:         python-flask
+Requires:         python-pecan >= 0.4.5
+Requires:         python-wsme >= 0.6
+Requires:         python-novaclient
+Requires:         python-keystoneclient
+Requires:         python-glanceclient
+Requires:         python-swiftclient
+Requires:         python-ceilometerclient
+Requires:         libvirt-python
 
 %description -n   python-ceilometer
 OpenStack ceilometer provides services to measure and
@@ -143,18 +173,38 @@ This package contains the central ceilometer agent.
 
 
 %package collector
-Summary:          OpenStack ceilometer collector agent
+Summary:          OpenStack ceilometer collector
 Group:            Applications/System
 
 Requires:         %{name}-common = %{version}-%{release}
 
+# For compat with older provisioning tools.
+# Remove when all reference the notification package explicitly
+Requires:         %{name}-notification
+
 Requires:         python-pymongo
 
 %description collector
 OpenStack ceilometer provides services to measure and
 collect metrics from OpenStack components.
 
-This package contains the ceilometer collector agent.
+This package contains the ceilometer collector service
+which collects metrics from the various agents.
+
+
+%package notification
+Summary:          OpenStack ceilometer notification agent
+Group:            Applications/System
+
+Requires:         %{name}-common = %{version}-%{release}
+
+%description notification
+OpenStack ceilometer provides services to measure and
+collect metrics from OpenStack components.
+
+This package contains the ceilometer notification agent
+which pushes metrics to the collector service from the
+various OpenStack services.
 
 
 %package api
@@ -165,8 +215,8 @@ Requires:         %{name}-common = %{version}-%{release}
 
 Requires:         python-pymongo
 Requires:         python-flask
-Requires:         python-pecan
-Requires:         python-wsme
+Requires:         python-pecan >= 0.4.5
+Requires:         python-wsme >= 0.6
 
 %description api
 OpenStack ceilometer provides services to measure and
@@ -175,6 +225,21 @@ collect metrics from OpenStack components.
 This package contains the ceilometer API service.
 
 
+%package alarm
+Summary:          OpenStack ceilometer alarm services
+Group:            Applications/System
+
+Requires:         %{name}-common = %{version}-%{release}
+Requires:         python-ceilometerclient
+
+%description alarm
+OpenStack ceilometer provides services to measure and
+collect metrics from OpenStack components.
+
+This package contains the ceilometer alarm notification
+and evaluation services.
+
+
 %if 0%{?with_doc}
 %package doc
 Summary:          Documentation for OpenStack ceilometer
@@ -260,6 +325,9 @@ install -p -D -m 755 %{SOURCE10} %{buildroot}%{_initrddir}/%{name}-api
 install -p -D -m 755 %{SOURCE11} %{buildroot}%{_initrddir}/%{name}-collector
 install -p -D -m 755 %{SOURCE12} %{buildroot}%{_initrddir}/%{name}-compute
 install -p -D -m 755 %{SOURCE13} %{buildroot}%{_initrddir}/%{name}-central
+install -p -D -m 755 %{SOURCE14} %{buildroot}%{_initrddir}/%{name}-alarm-notifier
+install -p -D -m 755 %{SOURCE15} %{buildroot}%{_initrddir}/%{name}-alarm-evaluator
+install -p -D -m 755 %{SOURCE16} %{buildroot}%{_initrddir}/%{name}-notification
 
 # Install upstart jobs examples
 install -d -m 755 %{buildroot}%{_datadir}/ceilometer
@@ -267,6 +335,9 @@ install -p -m 644 %{SOURCE100} %{buildroot}%{_datadir}/ceilometer/
 install -p -m 644 %{SOURCE110} %{buildroot}%{_datadir}/ceilometer/
 install -p -m 644 %{SOURCE120} %{buildroot}%{_datadir}/ceilometer/
 install -p -m 644 %{SOURCE130} %{buildroot}%{_datadir}/ceilometer/
+install -p -m 644 %{SOURCE140} %{buildroot}%{_datadir}/ceilometer/
+install -p -m 644 %{SOURCE150} %{buildroot}%{_datadir}/ceilometer/
+install -p -m 644 %{SOURCE160} %{buildroot}%{_datadir}/ceilometer/
 
 # Install logrotate
 install -p -D -m 644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
@@ -302,6 +373,12 @@ if [ $1 -eq 1 ] ; then
     /sbin/chkconfig --add %{name}-collector
 fi
 
+%post notification
+if [ $1 -eq 1 ] ; then
+    # Initial installation
+    /sbin/chkconfig --add %{name}-notification
+fi
+
 %post api
 if [ $1 -eq 1 ] ; then
     # Initial installation
@@ -314,6 +391,14 @@ if [ $1 -eq 1 ] ; then
     /sbin/chkconfig --add %{name}-central
 fi
 
+%post alarm
+if [ $1 -eq 1 ] ; then
+    # Initial installation
+    for svc in alarm-notifier alarm-evaluator; do
+        /sbin/chkconfig --add %{name}-${svc}
+    done
+fi
+
 %preun compute
 if [ $1 -eq 0 ] ; then
     for svc in compute; do
@@ -330,6 +415,14 @@ if [ $1 -eq 0 ] ; then
     done
 fi
 
+%preun notification
+if [ $1 -eq 0 ] ; then
+    for svc in notification; do
+        /sbin/service %{name}-${svc} stop > /dev/null 2>&1
+        /sbin/chkconfig --del %{name}-${svc}
+    done
+fi
+
 %preun api
 if [ $1 -eq 0 ] ; then
     for svc in api; do
@@ -346,6 +439,14 @@ if [ $1 -eq 0 ] ; then
     done
 fi
 
+%preun alarm
+if [ $1 -eq 0 ] ; then
+    for svc in alarm-notifier alarm-evaluator; do
+        /sbin/service %{name}-${svc} stop > /dev/null 2>&1
+        /sbin/chkconfig --del %{name}-${svc}
+    done
+fi
+
 %postun compute
 if [ $1 -ge 1 ] ; then
     # Package upgrade, not uninstall
@@ -362,6 +463,14 @@ if [ $1 -ge 1 ] ; then
     done
 fi
 
+%postun notification
+if [ $1 -ge 1 ] ; then
+    # Package upgrade, not uninstall
+    for svc in notification; do
+        /sbin/service %{name}-${svc} condrestart > /dev/null 2>&1 || :
+    done
+fi
+
 %postun api
 if [ $1 -ge 1 ] ; then
     # Package upgrade, not uninstall
@@ -378,6 +487,15 @@ if [ $1 -ge 1 ] ; then
     done
 fi
 
+%postun alarm
+/bin/systemctl daemon-reload >/dev/null 2>&1 || :
+if [ $1 -ge 1 ] ; then
+    # Package upgrade, not uninstall
+    for svc in alarm-notifier alarm-evaluator; do
+        /sbin/service %{name}-${svc} condrestart > /dev/null 2>&1 || :
+    done
+fi
+
 
 %files common
 %doc LICENSE
@@ -392,7 +510,10 @@ fi
 %dir %attr(0755, ceilometer, root) %{_localstatedir}/log/ceilometer
 %dir %attr(0755, ceilometer, root) %{_localstatedir}/run/ceilometer
 
-%{_bindir}/ceilometer-*
+%{_bindir}/ceilometer-dbsync
+%{_bindir}/ceilometer-expirer
+%{_bindir}/ceilometer-send-sample
+
 
 %defattr(-, ceilometer, ceilometer, -)
 %dir %{_sharedstatedir}/ceilometer
@@ -417,11 +538,17 @@ fi
 
 
 %files collector
-%{_bindir}/ceilometer-collector
+%{_bindir}/ceilometer-collector*
 %{_initrddir}/%{name}-collector
 %{_datarootdir}/ceilometer/%{name}-collector.upstart
 
 
+%files notification
+%{_bindir}/ceilometer-agent-notification
+%{_initrddir}/%{name}-notification
+%{_datarootdir}/ceilometer/%{name}-notification.upstart
+
+
 %files api
 %doc ceilometer/api/v1/static/LICENSE.*
 %{_bindir}/ceilometer-api
@@ -435,7 +562,69 @@ fi
 %{_datarootdir}/ceilometer/%{name}-central.upstart
 
 
+%files alarm
+%{_bindir}/ceilometer-alarm-notifier
+%{_bindir}/ceilometer-alarm-evaluator
+%{_initrddir}/%{name}-alarm-notifier
+%{_datarootdir}/ceilometer/%{name}-alarm-notifier.upstart
+%{_initrddir}/%{name}-alarm-evaluator
+%{_datarootdir}/ceilometer/%{name}-alarm-evaluator.upstart
+
+
 %changelog
+* Wed Jun 11 2014 Steve Linabery <slinaber@redhat.com> - 2014.1.1-2
+- Update to upstream 2014.1.1
+- fix message routing with newer QPID (rhbz#1103800)
+
+* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2014.1-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
+
+* Wed May 07 2014 Pádraig Brady <pbrady@redhat.com> - 2014.1-2
+- Avoid dependency issues with distributed installs (#1095414)
+
+* Thu Apr 17 2014 Pádraig Brady <pbrady@redhat.com> - 2014.1-1
+- Update to Icehouse release
+
+* Fri Apr 11 2014 Pádraig Brady <pbrady@redhat.com> - 2014.1-0.7.rc2
+- Update to upstream 2014.1.rc2
+- Remove qpid as default rpc backend
+- Split out openstack-ceilometer-notification subpackage from collector
+
+* Mon Mar 31 2014 Pádraig Brady <P@draigBrady.com> 2014.1-0.6.rc1
+- Update to upstream 2014.1.rc1
+
+* Fri Mar 14 2014 Pádraig Brady <pbrady@redhat.com> - 2014.1-0.5.b3
+- Update to Icehouse milestone 3
+
+* Tue Feb 04 2014 Pádraig Brady <pbrady@redhat.com> - 2014.1-0.4.b2
+- Fix missing dependency on python-babel
+
+* Mon Jan 27 2014 Pádraig Brady <pbrady@redhat.com> - 2014.1-0.3.b2
+- Update to Icehouse milestone 2
+
+* Mon Jan 06 2014 Pádraig Brady <pbrady@redhat.com> - 2014.1-0.2.b1
+- Set python-six min version to ensure updated
+
+* Mon Dec 23 2013 Pádraig Brady <pbrady@redhat.com> - 2014.1-0.1.b1
+- Update to Icehouse milestone 1
+
+* Tue Dec 17 2013 Pádraig Brady <pbrady@redhat.com> - 2013.2.1-1
+- Update to Havana stable release 2013.2.1
+
+* Thu Oct 17 2013 Pádraig Brady <pbrady@redhat.com> - 2013.2-1
+- Update to Havana release
+
+* Tue Oct 15 2013 Pádraig Brady <pbrady@redhat.com> - 2013.2-0.12.rc2
+- Update to Havana rc2
+- openstack-ceilometer-alarm now depends on python-ceilometerclient
+
+* Thu Oct 03 2013 Pádraig Brady <pbrady@redhat.com> - 2013.2-0.12.rc1
+- Update to Havana rc1
+- Separate out the new alarm services to the 'alarm' subpackage
+
+* Fri Sep 13 2013 Pádraig Brady <pbrady@redhat.com> - 2013.2-0.10.b3
+- Depend on python-oslo-config >= 1:1.2.0 so it upgraded automatically
+
 * Mon Sep 10 2013 Pádraig Brady <pbrady@redhat.com> - 2013.2-0.8.b3
 - Depend on python-pymongo rather than pymongo to avoid a puppet bug