Update specs to v. 2014.1.1
[openstack-build/ceilometer-build.git] / rpm / SPECS / openstack-ceilometer.spec
index e4c7063a414cc8e52196ae8e10409a23918d487d..a29b9958ea7e470e438feec5a548da449f58de61 100644 (file)
@@ -3,14 +3,14 @@
 %global pypi_name ceilometer
 
 Name:             openstack-ceilometer
-Version:          2014.1
-Release:          0.6.rc1%{?dist}
+Version:          2014.1.1
+Release:          2%{?dist}
 Summary:          OpenStack measurement collection service
 
 Group:            Applications/System
 License:          ASL 2.0
 URL:              https://wiki.openstack.org/wiki/Ceilometer
-Source0:          http://tarballs.openstack.org/%{pypi_name}/%{pypi_name}-%{version}.rc1.tar.gz
+Source0:          http://tarballs.openstack.org/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
 Source1:          %{pypi_name}-dist.conf
 Source2:          %{pypi_name}.logrotate
 
@@ -30,9 +30,9 @@ Source16:         %{name}-notification.init
 Source160:        %{name}-notification.upstart
 
 #
-# patches_base=2014.1.rc1
+# patches_base=2014.1.1
 #
-Patch0001: 0001-Ensure-we-don-t-access-the-net-when-building-docs.patch
+Patch0001: 0001-Ensure-routing-key-is-specified-in-the-address-for-a.patch
 
 # This is EL6 specific and not upstream
 Patch100:         openstack-ceilometer-newdeps.patch
@@ -63,7 +63,6 @@ Group:            Applications/System
 
 Requires:         python-qpid
 Requires:         python-kombu
-Requires:         python-amqplib
 
 Requires:         python-babel
 Requires:         python-eventlet
@@ -74,7 +73,7 @@ Requires:         python-anyjson
 Requires:         python-jsonpath-rw
 Requires:         python-stevedore >= 0.14
 Requires:         python-msgpack
-Requires:         python-six >= 1.4.1
+Requires:         python-six >= 1.6
 Requires:         PyYAML
 
 Requires:         python-sqlalchemy0.7
@@ -88,7 +87,20 @@ Requires:         python-oslo-config >= 1:1.2.0
 Requires:         pysnmp
 Requires:         pytz
 Requires:         python-croniter
-Requires:         python-pecan
+
+# These were only added as global dependencies
+# at the end of the Icehouse cycle with the change
+# to cli.py referenced from in http://pad.lv/1317210
+Requires:         python-pymongo
+Requires:         python-flask
+Requires:         python-pecan >= 0.4.5
+Requires:         python-wsme >= 0.6
+Requires:         python-novaclient
+Requires:         python-keystoneclient
+Requires:         python-glanceclient
+Requires:         python-swiftclient
+Requires:         python-ceilometerclient
+Requires:         libvirt-python
 
 %description -n   python-ceilometer
 OpenStack ceilometer provides services to measure and
@@ -128,7 +140,6 @@ Requires:         %{name}-common = %{version}-%{release}
 Requires:         python-novaclient
 Requires:         python-keystoneclient
 Requires:         libvirt-python
-Requires:         python-pecan
 
 %description compute
 OpenStack ceilometer provides services to measure and
@@ -157,18 +168,38 @@ This package contains the central ceilometer agent.
 
 
 %package collector
-Summary:          OpenStack ceilometer collector agent
+Summary:          OpenStack ceilometer collector
 Group:            Applications/System
 
 Requires:         %{name}-common = %{version}-%{release}
 
+# For compat with older provisioning tools.
+# Remove when all reference the notification package explicitly
+Requires:         %{name}-notification
+
 Requires:         python-pymongo
 
 %description collector
 OpenStack ceilometer provides services to measure and
 collect metrics from OpenStack components.
 
-This package contains the ceilometer collector agent.
+This package contains the ceilometer collector service
+which collects metrics from the various agents.
+
+
+%package notification
+Summary:          OpenStack ceilometer notification agent
+Group:            Applications/System
+
+Requires:         %{name}-common = %{version}-%{release}
+
+%description notification
+OpenStack ceilometer provides services to measure and
+collect metrics from OpenStack components.
+
+This package contains the ceilometer notification agent
+which pushes metrics to the collector service from the
+various OpenStack services.
 
 
 %package api
@@ -337,6 +368,12 @@ if [ $1 -eq 1 ] ; then
     /sbin/chkconfig --add %{name}-collector
 fi
 
+%post notification
+if [ $1 -eq 1 ] ; then
+    # Initial installation
+    /sbin/chkconfig --add %{name}-notification
+fi
+
 %post api
 if [ $1 -eq 1 ] ; then
     # Initial installation
@@ -367,7 +404,15 @@ fi
 
 %preun collector
 if [ $1 -eq 0 ] ; then
-    for svc in collector notification; do
+    for svc in collector; do
+        /sbin/service %{name}-${svc} stop > /dev/null 2>&1
+        /sbin/chkconfig --del %{name}-${svc}
+    done
+fi
+
+%preun notification
+if [ $1 -eq 0 ] ; then
+    for svc in notification; do
         /sbin/service %{name}-${svc} stop > /dev/null 2>&1
         /sbin/chkconfig --del %{name}-${svc}
     done
@@ -408,7 +453,15 @@ fi
 %postun collector
 if [ $1 -ge 1 ] ; then
     # Package upgrade, not uninstall
-    for svc in collector notification; do
+    for svc in collector; do
+        /sbin/service %{name}-${svc} condrestart > /dev/null 2>&1 || :
+    done
+fi
+
+%postun notification
+if [ $1 -ge 1 ] ; then
+    # Package upgrade, not uninstall
+    for svc in notification; do
         /sbin/service %{name}-${svc} condrestart > /dev/null 2>&1 || :
     done
 fi
@@ -481,10 +534,13 @@ fi
 
 %files collector
 %{_bindir}/ceilometer-collector*
-%{_bindir}/ceilometer-agent-notification
 %{_initrddir}/%{name}-collector
-%{_initrddir}/%{name}-notification
 %{_datarootdir}/ceilometer/%{name}-collector.upstart
+
+
+%files notification
+%{_bindir}/ceilometer-agent-notification
+%{_initrddir}/%{name}-notification
 %{_datarootdir}/ceilometer/%{name}-notification.upstart
 
 
@@ -511,6 +567,24 @@ fi
 
 
 %changelog
+* Wed Jun 11 2014 Steve Linabery <slinaber@redhat.com> - 2014.1.1-2
+- Update to upstream 2014.1.1
+- fix message routing with newer QPID (rhbz#1103800)
+
+* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2014.1-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
+
+* Wed May 07 2014 Pádraig Brady <pbrady@redhat.com> - 2014.1-2
+- Avoid dependency issues with distributed installs (#1095414)
+
+* Thu Apr 17 2014 Pádraig Brady <pbrady@redhat.com> - 2014.1-1
+- Update to Icehouse release
+
+* Fri Apr 11 2014 Pádraig Brady <pbrady@redhat.com> - 2014.1-0.7.rc2
+- Update to upstream 2014.1.rc2
+- Remove qpid as default rpc backend
+- Split out openstack-ceilometer-notification subpackage from collector
+
 * Mon Mar 31 2014 Pádraig Brady <P@draigBrady.com> 2014.1-0.6.rc1
 - Update to upstream 2014.1.rc1