Update ceilometer requirements for Fuel 5.1
[openstack-build/ceilometer-build.git] / rpm / SPECS / openstack-ceilometer.spec
index 7998873bf8cf53a5ee2ddcc048ab48a8a66f8dce..0ba7244ea06fb742e569cd39039debf3e1fd7a41 100644 (file)
@@ -3,8 +3,8 @@
 %global pypi_name ceilometer
 
 Name:             openstack-ceilometer
-Version:          2013.2
-Release:          1%{?dist}
+Version:          2014.1.1
+Release:          2%{?dist}
 Summary:          OpenStack measurement collection service
 
 Group:            Applications/System
@@ -26,11 +26,8 @@ Source14:         %{name}-alarm-notifier.init
 Source140:        %{name}-alarm-notifier.upstart
 Source15:         %{name}-alarm-evaluator.init
 Source150:        %{name}-alarm-evaluator.upstart
-
-#
-# patches_base=2013.2
-#
-Patch0001: 0001-Ensure-we-don-t-access-the-net-when-building-docs.patch
+Source16:         %{name}-notification.init
+Source160:        %{name}-notification.upstart
 
 # This is EL6 specific and not upstream
 Patch100:         openstack-ceilometer-newdeps.patch
@@ -46,8 +43,8 @@ BuildRequires:    python2-devel
 BuildRequires:    openstack-utils
 
 # These are required to build due to the requirements check added
-BuildRequires:    python-sqlalchemy0.7
-BuildRequires:    python-webob  >= 1.2
+BuildRequires:    python-sqlalchemy
+BuildRequires:    python-webob1.2
 
 
 %description
@@ -61,26 +58,54 @@ Group:            Applications/System
 
 Requires:         python-qpid
 Requires:         python-kombu
-Requires:         python-amqplib
 
+Requires:         python-babel
 Requires:         python-eventlet
 Requires:         python-greenlet
 Requires:         python-iso8601
 Requires:         python-lxml
 Requires:         python-anyjson
-Requires:         python-stevedore
+Requires:         python-jsonpath-rw
+Requires:         python-stevedore >= 0.14
 Requires:         python-msgpack
-Requires:         python-netaddr
 Requires:         python-six
 Requires:         PyYAML
 
-Requires:         python-sqlalchemy0.7
+Requires:         python-argparse
+Requires:         python-croniter >= 0.3.4
+Requires:         python-jsonschema
+Requires:         python-lockfile >= 0.8
+Requires:         python-netaddr
+Requires:         python-pbr
+Requires:         python-requests
+
+Requires:         python-sqlalchemy >= 0.7.8, python-sqlalchemy < 0.9.5, python-sqlalchemy > 0.9.5, python-sqlalchemy <= 0.9.99
 Requires:         python-alembic
-Requires:         python-migrate
+Requires:         python-migrate >= 0.8.2, python-migrate < 0.8.4, python-migrate > 0.8.4
+Requires:         python-happybase >= 0.5, python-happybase < 0.7, python-happybase > 0.7
 
-Requires:         python-webob >= 1.2
+Requires:         python-webob >= 1.2.3
 
 Requires:         python-oslo-config >= 1:1.2.0
+Requires:         python-oslo.vmware >= 0.2
+
+Requires:         pysnmp
+Requires:         pytz
+Requires:         python-croniter
+
+# These were only added as global dependencies
+# at the end of the Icehouse cycle with the change
+# to cli.py referenced from in http://pad.lv/1317210
+Requires:         python-pymongo
+Requires:         python-flask
+Requires:         python-pecan >= 0.4.5
+Requires:         python-wsme >= 0.6
+Requires:         python-novaclient
+Requires:         python-keystoneclient
+Requires:         python-glanceclient
+Requires:         python-swiftclient
+Requires:         python-ceilometerclient
+Requires:         libvirt-python
 
 %description -n   python-ceilometer
 OpenStack ceilometer provides services to measure and
@@ -148,18 +173,38 @@ This package contains the central ceilometer agent.
 
 
 %package collector
-Summary:          OpenStack ceilometer collector agent
+Summary:          OpenStack ceilometer collector
 Group:            Applications/System
 
 Requires:         %{name}-common = %{version}-%{release}
 
+# For compat with older provisioning tools.
+# Remove when all reference the notification package explicitly
+Requires:         %{name}-notification
+
 Requires:         python-pymongo
 
 %description collector
 OpenStack ceilometer provides services to measure and
 collect metrics from OpenStack components.
 
-This package contains the ceilometer collector agent.
+This package contains the ceilometer collector service
+which collects metrics from the various agents.
+
+
+%package notification
+Summary:          OpenStack ceilometer notification agent
+Group:            Applications/System
+
+Requires:         %{name}-common = %{version}-%{release}
+
+%description notification
+OpenStack ceilometer provides services to measure and
+collect metrics from OpenStack components.
+
+This package contains the ceilometer notification agent
+which pushes metrics to the collector service from the
+various OpenStack services.
 
 
 %package api
@@ -170,8 +215,8 @@ Requires:         %{name}-common = %{version}-%{release}
 
 Requires:         python-pymongo
 Requires:         python-flask
-Requires:         python-pecan
-Requires:         python-wsme
+Requires:         python-pecan >= 0.4.5
+Requires:         python-wsme >= 0.6
 
 %description api
 OpenStack ceilometer provides services to measure and
@@ -202,7 +247,7 @@ Group:            Documentation
 
 # Required to build module documents
 BuildRequires:    python-eventlet
-BuildRequires:    python-sqlalchemy0.7
+BuildRequires:    python-sqlalchemy
 BuildRequires:    python-webob
 # while not strictly required, quiets the build down when building docs.
 BuildRequires:    python-migrate, python-iso8601
@@ -217,8 +262,6 @@ This package contains documentation files for ceilometer.
 %prep
 %setup -q -n ceilometer-%{version}
 
-%patch0001 -p1
-
 # Apply EL6 patch
 %patch100 -p1
 
@@ -282,6 +325,7 @@ install -p -D -m 755 %{SOURCE12} %{buildroot}%{_initrddir}/%{name}-compute
 install -p -D -m 755 %{SOURCE13} %{buildroot}%{_initrddir}/%{name}-central
 install -p -D -m 755 %{SOURCE14} %{buildroot}%{_initrddir}/%{name}-alarm-notifier
 install -p -D -m 755 %{SOURCE15} %{buildroot}%{_initrddir}/%{name}-alarm-evaluator
+install -p -D -m 755 %{SOURCE16} %{buildroot}%{_initrddir}/%{name}-notification
 
 # Install upstart jobs examples
 install -d -m 755 %{buildroot}%{_datadir}/ceilometer
@@ -291,6 +335,7 @@ install -p -m 644 %{SOURCE120} %{buildroot}%{_datadir}/ceilometer/
 install -p -m 644 %{SOURCE130} %{buildroot}%{_datadir}/ceilometer/
 install -p -m 644 %{SOURCE140} %{buildroot}%{_datadir}/ceilometer/
 install -p -m 644 %{SOURCE150} %{buildroot}%{_datadir}/ceilometer/
+install -p -m 644 %{SOURCE160} %{buildroot}%{_datadir}/ceilometer/
 
 # Install logrotate
 install -p -D -m 644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
@@ -326,6 +371,12 @@ if [ $1 -eq 1 ] ; then
     /sbin/chkconfig --add %{name}-collector
 fi
 
+%post notification
+if [ $1 -eq 1 ] ; then
+    # Initial installation
+    /sbin/chkconfig --add %{name}-notification
+fi
+
 %post api
 if [ $1 -eq 1 ] ; then
     # Initial installation
@@ -362,6 +413,14 @@ if [ $1 -eq 0 ] ; then
     done
 fi
 
+%preun notification
+if [ $1 -eq 0 ] ; then
+    for svc in notification; do
+        /sbin/service %{name}-${svc} stop > /dev/null 2>&1
+        /sbin/chkconfig --del %{name}-${svc}
+    done
+fi
+
 %preun api
 if [ $1 -eq 0 ] ; then
     for svc in api; do
@@ -402,6 +461,14 @@ if [ $1 -ge 1 ] ; then
     done
 fi
 
+%postun notification
+if [ $1 -ge 1 ] ; then
+    # Package upgrade, not uninstall
+    for svc in notification; do
+        /sbin/service %{name}-${svc} condrestart > /dev/null 2>&1 || :
+    done
+fi
+
 %postun api
 if [ $1 -ge 1 ] ; then
     # Package upgrade, not uninstall
@@ -443,6 +510,7 @@ fi
 
 %{_bindir}/ceilometer-dbsync
 %{_bindir}/ceilometer-expirer
+%{_bindir}/ceilometer-send-sample
 
 
 %defattr(-, ceilometer, ceilometer, -)
@@ -473,6 +541,12 @@ fi
 %{_datarootdir}/ceilometer/%{name}-collector.upstart
 
 
+%files notification
+%{_bindir}/ceilometer-agent-notification
+%{_initrddir}/%{name}-notification
+%{_datarootdir}/ceilometer/%{name}-notification.upstart
+
+
 %files api
 %doc ceilometer/api/v1/static/LICENSE.*
 %{_bindir}/ceilometer-api
@@ -496,6 +570,45 @@ fi
 
 
 %changelog
+* Wed Jun 11 2014 Steve Linabery <slinaber@redhat.com> - 2014.1.1-2
+- Update to upstream 2014.1.1
+- fix message routing with newer QPID (rhbz#1103800)
+
+* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2014.1-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
+
+* Wed May 07 2014 Pádraig Brady <pbrady@redhat.com> - 2014.1-2
+- Avoid dependency issues with distributed installs (#1095414)
+
+* Thu Apr 17 2014 Pádraig Brady <pbrady@redhat.com> - 2014.1-1
+- Update to Icehouse release
+
+* Fri Apr 11 2014 Pádraig Brady <pbrady@redhat.com> - 2014.1-0.7.rc2
+- Update to upstream 2014.1.rc2
+- Remove qpid as default rpc backend
+- Split out openstack-ceilometer-notification subpackage from collector
+
+* Mon Mar 31 2014 Pádraig Brady <P@draigBrady.com> 2014.1-0.6.rc1
+- Update to upstream 2014.1.rc1
+
+* Fri Mar 14 2014 Pádraig Brady <pbrady@redhat.com> - 2014.1-0.5.b3
+- Update to Icehouse milestone 3
+
+* Tue Feb 04 2014 Pádraig Brady <pbrady@redhat.com> - 2014.1-0.4.b2
+- Fix missing dependency on python-babel
+
+* Mon Jan 27 2014 Pádraig Brady <pbrady@redhat.com> - 2014.1-0.3.b2
+- Update to Icehouse milestone 2
+
+* Mon Jan 06 2014 Pádraig Brady <pbrady@redhat.com> - 2014.1-0.2.b1
+- Set python-six min version to ensure updated
+
+* Mon Dec 23 2013 Pádraig Brady <pbrady@redhat.com> - 2014.1-0.1.b1
+- Update to Icehouse milestone 1
+
+* Tue Dec 17 2013 Pádraig Brady <pbrady@redhat.com> - 2013.2.1-1
+- Update to Havana stable release 2013.2.1
+
 * Thu Oct 17 2013 Pádraig Brady <pbrady@redhat.com> - 2013.2-1
 - Update to Havana release