Disable debug while build
[packages/centos6/kernel.git] / kernel.spec
index e9565f654289b0ce055e0b018bdd383488541795..f239a8c0b8713f215a7b8cda05dda89a252ca9a4 100644 (file)
@@ -94,7 +94,7 @@ Summary: The Linux kernel
 # kernel-kdump
 %define with_kdump     %{?_without_kdump:     0} %{?!_without_kdump:     1}
 # kernel-debug
-%define with_debug     %{?_without_debug:     0} %{?!_without_debug:     1}
+%define with_debug     %{?_without_debug:     0} %{?!_without_debug:     0}
 # kernel-doc
 %define with_doc       %{?_without_doc:       0} %{?!_without_doc:       1}
 # kernel-headers
@@ -104,7 +104,7 @@ Summary: The Linux kernel
 # perf noarch subpkg
 %define with_perf      %{?_without_perf:      0} %{?!_without_perf:      1}
 # kernel-debuginfo
-%define with_debuginfo %{?_without_debuginfo: 0} %{?!_without_debuginfo: 1}
+%define with_debuginfo %{?_without_debuginfo: 0} %{?!_without_debuginfo: 0}
 # kernel-bootwrapper (for creating zImages from kernel + initrd)
 %define with_bootwrapper %{?_without_bootwrapper: 0} %{?!_without_bootwrapper: 1}
 # Want to build a the vsdo directories installed
@@ -143,7 +143,7 @@ Summary: The Linux kernel
 # Set debugbuildsenabled to 1 for production (build separate debug kernels)
 #  and 0 for rawhide (all kernels are debug kernels).
 # See also 'make debug' and 'make release'.
-%define debugbuildsenabled 1
+%define debugbuildsenabled 0
 
 # pkg_release is what we'll fill in for the rpm Release: field
 %if 0%{?released_kernel}
@@ -304,6 +304,10 @@ Summary: The Linux kernel
 %define image_install_path boot
 %define kernel_image arch/x86/boot/bzImage
 #HACK for obs
+%define with_up 0
+%define with_headers 0
+%define with_perf 0
+%define all_arch_configs kernel-%{version}-*.config
 %define with_firmware 1
 %endif
 
@@ -1328,7 +1332,7 @@ mkdir -p $RPM_BUILD_ROOT/boot
 cd linux-%{KVERREL}
 
 #HACK for obs to access rights for find-provides script
-chmod +x %__find_provides 
+chmod +x %_sourcedir/find-provides
 
 %if %{with_up}
 BuildKernel %make_target %kernel_image