kernel repackaged for 7.0
[packages/centos6/kernel.git] / kernel.spec
index 44eab6094aa7767bd6c80296229ce6a9377dddc7..1edb35a77d86c434d7ce15afb41f26734f839196 100644 (file)
@@ -6,6 +6,7 @@ Summary: The Linux kernel
 # and/or a kernel built from an rc or git snapshot, released_kernel should
 # be 0.
 %define released_kernel 1
+%define dist .el6
 
 # Versions of various parts
 
@@ -14,9 +15,9 @@ Summary: The Linux kernel
 # that the kernel isn't the stock distribution kernel, for example,
 # by setting the define to ".local" or ".bz123456"
 #
-# % define buildid .local
+%define buildid .mos62
 
-%define distro_build 504
+%define distro_build 504.1.3
 %define signmodules 1
 
 # if patch fuzzy patch applying will be forbidden
@@ -153,7 +154,7 @@ Summary: The Linux kernel
 %endif
 
 # The kernel tarball/base version
-%define kversion 2.6.32-504.el6
+%define kversion 2.6.32-504.1.3.el6
 
 %define make_target bzImage
 
@@ -543,7 +544,7 @@ BuildConflicts: rhbuildsys(DiskFree) < 7Gb
 %define strip_cmd strip
 %endif
 
-Source0: linux-2.6.32-504.el6.tar.bz2
+Source0: linux-2.6.32-504.1.3.el6.tar.bz2
 
 Source1: Makefile.common
 
@@ -613,6 +614,8 @@ Source84: config-s390x-generic-rhel
 Source85: config-powerpc64-debug-rhel
 Source86: config-s390x-debug-rhel
 
+# Fix LP#1456605
+Patch1: fix-do_tcp_sendpages.patch
 # empty final patch file to facilitate testing of kernel patches
 Patch999999: linux-kernel-test.patch
 
@@ -935,6 +938,7 @@ cp %{SOURCE15} %{SOURCE1} %{SOURCE16} %{SOURCE17} %{SOURCE18} .
 # Dynamically generate kernel .config files from config-* files
 make -f %{SOURCE20} VERSION=%{version} configs
 
+ApplyPatch fix-do_tcp_sendpages.patch
 ApplyOptionalPatch linux-kernel-test.patch
 
 # Any further pre-build tree manipulations happen here.
@@ -1001,7 +1005,7 @@ EOF
 if [ -s %{SOURCE19} ]; then
        gpg --homedir . --no-default-keyring --keyring kernel.pub --import %{SOURCE19}
 fi
-gpg --homedir . --export --keyring ./kernel.pub Red > extract.pub
+gpg --homedir . --export --keyring ./kernel.pub CentOS > extract.pub
 gcc -o scripts/bin2c scripts/bin2c.c
 scripts/bin2c ksign_def_public_key __initdata <extract.pub >crypto/signature/key.h
 %endif
@@ -1738,6 +1742,26 @@ fi
 %endif
 
 %changelog
+* Tue Nov 11 2014 Johnny Hughes <johnny@centos.org> [2.6.32-504.1.3.el6]
+- Roll in CentOS Branding
+
+* Fri Oct 31 2014 Radomir Vrbovsky <rvrbovsk@redhat.com> [2.6.32-504.1.3.el6]
+- Revert: [net] revert "bridge: Set vlan_features to allow offloads on vlans" (Vlad Yasevich) [1144442 1121991]
+
+* Wed Oct 15 2014 Radomir Vrbovsky <rvrbovsk@redhat.com> [2.6.32-504.1.2.el6]
+- [x86] kvm: fix PIT timer race condition (mguzik) [1149592 1149593] {CVE-2014-3611}
+- [x86] kvm: vmx: handle invept and invvpid vm exits gracefull (mguzik) [1144826 1144837 1144827 1144838] {CVE-2014-3646 CVE-2014-3645}
+
+* Fri Oct 10 2014 Radomir Vrbovsky <rvrbovsk@redhat.com> [2.6.32-504.1.1.el6]
+- [fs] call d_op->d_hash on last component of umount path (Abhijith Das) [1145193 1129712]
+- [usb] serial: memory corruption flaw (Jacob Tanenbaum) [1141401 1141402] {CVE-2014-3185}
+- [char] ipmi: Clear drvdata when interface is removed (Tony Camuso) [1149578 1135910]
+- [char] ipmi: init shadow_ipmi_smi_handlers early in ipmi_si_intf (Tony Camuso) [1149580 1139464]
+- [net] ipsec: update MAX_AH_AUTH_LEN to support sha512 (Herbert Xu) [1149083 1140103]
+- [net] revert "bridge: Set vlan_features to allow offloads on vlans" (Vlad Yasevich) [1144442 1121991]
+- [netdrv] virtio-net: fix big buffer receiving (Jason Wang) [1148693 1144073]
+- [netdrv] tg3: prevent ifup/ifdown during PCI error recovery (Ivan Vecera) [1142570 1117009]
+
 * Tue Sep 16 2014 Rafael Aquini <aquini@redhat.com> [2.6.32-504.el6]
 - [netdrv] revert "cxgb4: set skb->rxhash" (Prarit Bhargava) [1140743]
 - [netdrv] revert "cxgb4: Use netif_set_real_num_rx/tx_queues()" (Prarit Bhargava) [1140743]