Update version according to OSCI-883
[packages/precise/mcollective.git] / ext / Makefile.debian
diff --git a/ext/Makefile.debian b/ext/Makefile.debian
deleted file mode 100644 (file)
index dbb3ac7..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-#!/usr/bin/make -f
-
-# This is the makefile used by debian/rules when invoked by rake deb
-
-DESTDIR=
-
-build:
-
-clean:
-
-install: install-bin install-lib install-conf install-plugins install-doc
-
-install-bin:
-       install -d $(DESTDIR)/usr/sbin
-       install -d $(DESTDIR)/usr/bin
-       cp bin/mc-* $(DESTDIR)/usr/sbin
-       cp bin/mco $(DESTDIR)/usr/bin
-       cp bin/mcollectived $(DESTDIR)/usr/sbin/mcollectived
-
-install-lib:
-       install -d $(DESTDIR)/usr/lib/ruby/vendor_ruby/
-       cp -a lib/* $(DESTDIR)/usr/lib/ruby/vendor_ruby/
-
-install-conf:
-       install -d $(DESTDIR)/etc/mcollective/
-       install -d $(DESTDIR)/etc/init.d
-       cp -r etc/* $(DESTDIR)/etc/mcollective/
-       cp mcollective.init $(DESTDIR)/etc/init.d/mcollective
-       rm $(DESTDIR)/etc/mcollective/ssl/PLACEHOLDER
-       rm $(DESTDIR)/etc/mcollective/ssl/clients/PLACEHOLDER
-
-install-plugins:
-       install -d $(DESTDIR)/usr/share/mcollective/
-       cp -a plugins $(DESTDIR)/usr/share/mcollective/
-
-install-doc:
-       install -d $(DESTDIR)/usr/share/doc/
-       cp -a doc  $(DESTDIR)/usr/share/doc/mcollective
-
-uninstall:
-       rm -f $(DESTDIR)/usr/sbin/mcollectived
-       rm -rf $(DESTDIR)/usr/lib/ruby/1.8/mcollective*
-       rm -rf $(DESTDIR)/usr/share/mcollective
-       rm -rf $(DESTDIR)/etc/mcollective
-
-.PHONY: build clean install uninstall