Remove tests stuff
[openstack-build/cinder-build.git] / debian / rules
diff --git a/debian/rules b/debian/rules
deleted file mode 100755 (executable)
index 0c37cb6..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/usr/bin/make -f
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-DEBVERS ?= $(shell dpkg-parsechangelog | sed -n -e 's/^Version: //p')
-VERSION ?= $(shell echo '$(DEBVERS)' | sed -e 's/^[[:digit:]]*://' -e 's/[-].*//')
-export OSLO_PACKAGE_VERSION=$(VERSION)
-
-%:
-       dh $@  --with python2
-
-get-orig-source:
-       uscan --verbose --rename --destdir=../build-area
-
-ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
-override_dh_auto_test:
-       PYTHONPATH=$(CURDIR) bash run_tests.sh -N
-endif
-
-override_dh_install:
-       dh_install --fail-missing -Xbin/cinder-all
-
-override_dh_fixperms:
-       dh_fixperms -Xcinder_tgt.conf