Fix logrotate postrotate command
[packages/centos7/cobbler.git] / cobbler.spec
index 63676e301a8304e6cccb6f314618c18b3f053e65..e616292e1f2f0b556903651e9fa6e81002ad80ad 100644 (file)
@@ -16,8 +16,9 @@ Name: cobbler
 License: GPLv2+
 AutoReq: no
 Version: 2.6.9
-Release: 1%{?dist}~mos10
+Release: 1%{?dist}~mos13
 Source0: https://github.com/cobbler/cobbler/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
+Source1: cobblerd.logrotate
 # Support newer virt-install - https://bugzilla.redhat.com/show_bug.cgi?id=1188424
 Patch0: cobbler-virtinstall.patch
 # Support centos release numbering
@@ -28,6 +29,10 @@ Patch1: cobbler-centos.patch
 Patch2: cobbler-django17.patch
 # Add ALLOWED_HOSTS into djando settings
 Patch3: Mirantis-Add-ALLOWED_HOSTS-for-settings.patch
+# Add signatures for Ubuntu 16.04 and Fedora 24
+Patch4: Mirantis-Signatures-for-Ubuntu-16.04-and-Fedora-24.patch
+# Fix bug 1603615 - mangling kernel options with the key --in-place
+Patch5: Mirantis-mangling-kopts-bugfix.patch
 
 Group: Applications/System
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
@@ -93,6 +98,8 @@ other applications.
 %if 0%{?fedora} >= 22 || 0%{?rhel} >= 6
 %patch2 -p1 -b .django17
 %patch3 -p1
+%patch4 -p1
+%patch5 -p1
 %endif
 
 %build
@@ -106,7 +113,11 @@ test "x$RPM_BUILD_ROOT" != "x" && rm -rf $RPM_BUILD_ROOT
 rm $RPM_BUILD_ROOT%{_sysconfdir}/cobbler/cobbler.conf
 
 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
+%if 0%{?rhel} < 7
 mv $RPM_BUILD_ROOT%{_sysconfdir}/cobbler/cobblerd_rotate $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/cobblerd
+%else
+mv %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/cobblerd
+%endif
 
 # Create data directories in tftp_dir
 mkdir -p $RPM_BUILD_ROOT%{tftp_dir}/{boot,etc,grub,images{,2},ppc,pxelinux.cfg,s390x}
@@ -288,6 +299,12 @@ sed -i -e "s/SECRET_KEY = ''/SECRET_KEY = \'$RAND_SECRET\'/" /usr/share/cobbler/
 
 
 %changelog
+* Tue Jul 27 2016 Albert Syriy <mos-linux-team@mirantis.com> - 2.6.9-1~mos12
+- Add patch to fix the LP bug 1603615 (mangling kernel options)
+
+* Tue Jun 13 2016 Dmitry Teselkkin <mos-linux-team@mirantis.com> - 2.6.9-1~mos11
+- Add patch to add signatures for Ubuntu 16.04
+
 * Thu May 19 2016 Ivan Suzdal <mos-linux-team@mirantis.com> - 2.6.9-1~mos10
 - Add patch to fix 'error 400' for cobbler-web (LP: #1583648)
 - Bump version