Fix logrotate postrotate command
[packages/centos7/cobbler.git] / cobbler.spec
index ef214d6c7d1ae7fb2e3b8de4e7ce33318ba0e3cf..e616292e1f2f0b556903651e9fa6e81002ad80ad 100644 (file)
@@ -16,8 +16,9 @@ Name: cobbler
 License: GPLv2+
 AutoReq: no
 Version: 2.6.9
-Release: 1%{?dist}~mos11
+Release: 1%{?dist}~mos13
 Source0: https://github.com/cobbler/cobbler/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
+Source1: cobblerd.logrotate
 # Support newer virt-install - https://bugzilla.redhat.com/show_bug.cgi?id=1188424
 Patch0: cobbler-virtinstall.patch
 # Support centos release numbering
@@ -30,6 +31,8 @@ Patch2: cobbler-django17.patch
 Patch3: Mirantis-Add-ALLOWED_HOSTS-for-settings.patch
 # Add signatures for Ubuntu 16.04 and Fedora 24
 Patch4: Mirantis-Signatures-for-Ubuntu-16.04-and-Fedora-24.patch
+# Fix bug 1603615 - mangling kernel options with the key --in-place
+Patch5: Mirantis-mangling-kopts-bugfix.patch
 
 Group: Applications/System
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
@@ -96,6 +99,7 @@ other applications.
 %patch2 -p1 -b .django17
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 %endif
 
 %build
@@ -109,7 +113,11 @@ test "x$RPM_BUILD_ROOT" != "x" && rm -rf $RPM_BUILD_ROOT
 rm $RPM_BUILD_ROOT%{_sysconfdir}/cobbler/cobbler.conf
 
 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
+%if 0%{?rhel} < 7
 mv $RPM_BUILD_ROOT%{_sysconfdir}/cobbler/cobblerd_rotate $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/cobblerd
+%else
+mv %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/cobblerd
+%endif
 
 # Create data directories in tftp_dir
 mkdir -p $RPM_BUILD_ROOT%{tftp_dir}/{boot,etc,grub,images{,2},ppc,pxelinux.cfg,s390x}
@@ -291,6 +299,9 @@ sed -i -e "s/SECRET_KEY = ''/SECRET_KEY = \'$RAND_SECRET\'/" /usr/share/cobbler/
 
 
 %changelog
+* Tue Jul 27 2016 Albert Syriy <mos-linux-team@mirantis.com> - 2.6.9-1~mos12
+- Add patch to fix the LP bug 1603615 (mangling kernel options)
+
 * Tue Jun 13 2016 Dmitry Teselkkin <mos-linux-team@mirantis.com> - 2.6.9-1~mos11
 - Add patch to add signatures for Ubuntu 16.04