libunwind package for centos7 MOS 8
[packages/centos7/libunwind.git] / libunwind.spec
1 # rpmbuild parameters:
2 # --without check: Do not run the testsuite.  Default is to run it.
3
4 Summary: An unwinding library
5 Name: libunwind
6 Version: 1.1
7 Release: 10%{?dist}~mos8.0.1
8 License: BSD
9 Group: Development/Debuggers
10 Source: http://download.savannah.gnu.org/releases/libunwind/libunwind-%{version}.tar.gz
11 #Fedora specific patch
12 Patch1: libunwind-disable-setjmp.patch
13 Patch2: libunwind-aarch64.patch
14 Patch3: libunwind-fix-ppc64_test_altivec.patch
15 Patch4: libunwind-arm-default-to-exidx.patch
16 Patch5: libunwind-1.1-fix-CVE-2015-3239.patch
17 URL: http://savannah.nongnu.org/projects/libunwind
18 ExclusiveArch: %{arm} aarch64 hppa ia64 mips ppc %{power64} %{ix86} x86_64
19
20 BuildRequires: automake libtool autoconf
21
22 # host != target would cause REMOTE_ONLY build even if building i386 on x86_64.
23 %global _host %{_target_platform}
24
25 %description
26 Libunwind provides a C ABI to determine the call-chain of a program.
27
28 %package devel
29 Summary: Development package for libunwind
30 Group: Development/Debuggers
31 Requires: libunwind = %{version}-%{release}
32
33 %description devel
34 The libunwind-devel package includes the libraries and header files for
35 libunwind.
36
37 %prep
38 %setup -q
39 %patch1 -p1
40 %patch2 -p1
41 %patch3 -p1
42 %patch4 -p1 -b .default-to-exidx
43 %patch5 -p1 -b .CVE-2015-3239
44
45 %build
46 aclocal
47 libtoolize --force
48 autoheader
49 automake --add-missing
50 autoconf
51 %configure --enable-static --enable-shared
52 make %{?_smp_mflags}
53
54 %install
55 make install DESTDIR=$RPM_BUILD_ROOT
56 find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
57
58 # /usr/include/libunwind-ptrace.h
59 # [...] aren't really part of the libunwind API.  They are implemented in
60 # a archive library called libunwind-ptrace.a.
61 mv -f $RPM_BUILD_ROOT%{_libdir}/libunwind-ptrace.a $RPM_BUILD_ROOT%{_libdir}/libunwind-ptrace.a-save
62 rm -f $RPM_BUILD_ROOT%{_libdir}/libunwind*.a
63 mv -f $RPM_BUILD_ROOT%{_libdir}/libunwind-ptrace.a-save $RPM_BUILD_ROOT%{_libdir}/libunwind-ptrace.a
64 rm -f $RPM_BUILD_ROOT%{_libdir}/libunwind-ptrace*.so*
65
66 %check
67 %if 0%{?_with_check:1} || 0%{?_with_testsuite:1}
68 echo ====================TESTING=========================
69 make check || true
70 echo ====================TESTING END=====================
71 %else
72 echo ====================TESTSUITE DISABLED=========================
73 %endif
74
75 %post -p /sbin/ldconfig
76
77 %postun -p /sbin/ldconfig
78
79 %files
80 %defattr(-,root,root,-)
81 %doc COPYING README NEWS
82 %{_libdir}/libunwind*.so.*
83
84 %files devel
85 %defattr(-,root,root,-)
86 %{_libdir}/libunwind*.so
87 %{_libdir}/libunwind-ptrace.a
88 %{_libdir}/pkgconfig/libunwind*.pc
89 %{_mandir}/*/*
90 # <unwind.h> does not get installed for REMOTE_ONLY targets - check it.
91 %{_includedir}/unwind.h
92 %{_includedir}/libunwind*.h
93
94 %changelog
95 * Fri Oct  2 2015 Ivan Suzdal <isuzdal@mirantis.com> - 1.1-10%{?dist}~mos8.0.1
96 - Rebuilt for MOS 8
97 - Append ~mosX.X.X to Release
98
99 * Fri Jul 10 2015 Tom Callaway <spot@fedoraproject.org> - 1.1-10
100 - fix CVE-2015-3239
101
102 * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-9
103 - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
104
105 * Tue Jun  2 2015 Tom Callaway <spot@fedoraproject.org> - 1.1-8 
106 - default arm unwinding method to exidx, old default of dwarf never works on Fedora
107   (#1226806)
108
109 * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-7
110 - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
111
112 * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-6
113 - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
114
115 * Tue May 13 2014 Jaromir Capik <jcapik@redhat.com> - 1.1-5
116 - Replacing ppc64 with the power64 macro (#1051641)
117
118 * Mon Jan 20 2014 Kyle McMartin <kmcmarti@redhat.com> 1.1-4
119 - Link test_ppc64_altivec against libunwind in tests/Makefile.am to fix build
120   on ppc64.
121
122 * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-3
123 - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
124
125 * Mon Jun 03 2013 Kyle McMartin <kmcmarti@redhat.com> 1.1-2
126 - Add aarch64 support from backported ac6c0a65. (Mark Salter)
127   (rhbz#969689)
128
129 * Mon Feb 18 2013 Kyle McMartin <kmcmarti@redhat.com> 1.1-1
130 - Update to upstream v1.1
131 - libunwind-install-ptrace.patch: drop upstream patch
132 - libunwind-arm-register-rename.patch: fixed upstream
133 - Add pkg-config files to libunwind-devel
134
135 * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.1-5
136 - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
137
138 * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.1-4
139 - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
140
141 * Wed Feb 15 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 1.0.1-3
142 - Add patch to fix build on ARM
143
144 * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.1-2
145 - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
146
147 * Thu Sep 15 2011 Jan Kratochvil <jan.kratochvil@redhat.com> - 1.0.1-1.fc17
148 - Upgrade to the upstream release. (BZ 738595).
149 - Use official distribution URL for %%{source}.
150
151 * Thu Jun 02 2011 Paul Whalen <paul.whalen@senecac.on.ca> - 0.99-3.20110424git1e10c293
152 - Added arm macro to ExclusiveArch
153
154 * Mon May  9 2011 Jan Kratochvil <jan.kratochvil@redhat.com> - 0.99-2.20110424git1e10c293
155 - Install static libunwind-ptrace library into system (for ltrace, BZ 703159).
156
157 * Sun Apr 24 2011 Jan Kratochvil <jan.kratochvil@redhat.com> - 0.99-1.20110424git1e10c293
158 - Rebase to the upstream post-0.99 snapshot (BZ 697453).
159
160 * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.99-0.16.20090430betagit4b8404d1
161 - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
162
163 * Wed Sep 29 2010 jkeating - 0.99-0.15.20090430betagit4b8404d1
164 - Rebuilt for gcc bug 634757
165
166 * Sat Sep 11 2010 Parag Nemade <paragn AT fedoraproject.org> 0.99-0.14.20090430betagit4b8404d1.fc15
167 - Merge-review cleanup (#226052)
168
169 * Fri Dec  4 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.99-0.13.20090430betagit4b8404d1
170 - The devel package now requires also base package's %{release}.
171 - Update the obsolete macro %%{package_version}.
172
173 * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.99-0.12.20090430betagit4b8404d1
174 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
175
176 * Wed Jul 15 2009 Jan Kratochvil <jan.kratochvil@redhat.com> - 0.99-0.11.20090430betagit4b8404d1
177 - Disable the libunwind-setjmp library as no longer compatible with glibc and
178   no Fedora dependencies on it (FTBSFS BZ 511562).
179
180 * Thu Apr 30 2009 Jan Kratochvil <jan.kratochvil@redhat.com> - 0.99-0.10.20090430betagit4b8404d1
181 - Fix the ia64 variant of GetIPInfo() (BZ 480412).
182
183 * Mon Apr 13 2009 Jan Kratochvil <jan.kratochvil@redhat.com> - 0.99-0.9.20090413betagitb483ea3f
184 - Rebase the package on the upstream variant: http://www.nongnu.org/libunwind/
185   - Drop the patch libunwind-snap-070224-frysk20070405cvs.patch
186     as even frysk-0.4-8.fc11 still has this library bundled statically.
187 - Disable the testsuite by default during the build.
188   - It should be run separately as it crashes some ia64 kernels.
189   - Drop the patch libunwind-snap-070224-orphanripper.patch.
190 - Drop the patch libunwind-snap-070224-dprintf-vs-stdio.h as no longer needed.
191 - Drop libunwind-snap-070224-multilib-rh342451.patch as accepted upstream.
192 - Fix and enable ppc (ppc32) arch.
193
194 * Tue Mar  3 2009 Jan Kratochvil <jan.kratochvil@redhat.com> - 0.99-0.8.frysk20070405cvs
195 - Fix .spec ExclusiveArch from i386 to %%{ix86}.
196 - Remove `BuildRequires: glibc gcc make tar gzip' - minimum build environment.
197
198 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.99-0.7.frysk20070405cvs
199 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
200
201 * Mon Sep 22 2008 Jan Kratochvil <jan.kratochvil@redhat.com> - 0.99-0.6.frysk20070405cvs
202 - Fix build error due to a `dprintf' conflict on recent glibc.
203 - New rpmbuild parameter: --without check
204
205 * Sun Feb 24 2008 Jan Kratochvil <jan.kratochvil@redhat.com> - 0.99-0.5.frysk20070405cvs
206 - Fix the multilib conflicts (BZ 342451).
207
208 * Sun Feb 24 2008 Jan Kratochvil <jan.kratochvil@redhat.com> - 0.99-0.4.frysk20070405cvs
209 - Abort the possibly hung up testcases after 120 seconds (BZ 427850, BZ 434147).
210
211 * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.99-0.3.frysk20070405cvs
212 - Autorebuild for GCC 4.3
213
214 * Sun Apr 22 2007 Jan Kratochvil <jan.kratochvil@redhat.com> - 0.99-0.2.frysk20070405cvs
215 - Require conflict with gdb < gdb-6.6-9 as it would not find `libunwind.so'.
216 - Fixed (unused - commented) rule for a RPM build with embedded debug info.
217
218 * Thu Apr  5 2007 Jan Kratochvil <jan.kratochvil@redhat.com> - 0.99-0.1.frysk20070405cvs
219 - Update to the upstream snapshot snap-070224.
220 - Use the Frysk's modified version, currently snapshot 20070405cvs.
221 - Extend the supported architectures from ia64 also to x86_64, i386 and ppc64.
222 - Spec file fixups.
223 - Split the package to its base and the `devel' part.
224 - Drop the statically built libraries.
225
226 * Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 0.98.5-3
227 - rebuilt for unwind info generation, broken in gcc-4.1.1-21
228
229 * Sat Sep 22 2006 Jan Kratochvil <jan.kratochvil@redhat.com> - 0.98.5-2
230 - SELinux compatibility fix - stack is now non-exec (Jakub Jelinek suggestion).
231
232 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.98.5-1.1
233 - rebuild
234
235 * Sat May 27 2006 Alexandre Oliva <aoliva@redhat.com> - 0.98.5-1
236 - Import version 0.98.5.
237
238 * Thu Feb 09 2006 Florian La Roche <laroche@redhat.com>
239 - remove empty scripts
240
241 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.98.2-3.2
242 - rebuilt for new gcc4.1 snapshot and glibc changes
243
244 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
245 - rebuilt
246
247 * Tue Mar 01 2005 Jeff Johnston <jjohnstn@redhat.com>   0.98.2.3
248 - Bump up release number
249
250 * Thu Nov 11 2004 Jeff Johnston <jjohnstn@redhat.com>   0.98.2.2
251 - Import version 0.98.2.
252
253 * Wed Nov 10 2004 Jeff Johnston <jjohnstn@redhat.com>   0.97.6
254 - Bump up release number
255
256 * Thu Aug 19 2004 Jeff Johnston <jjohnstn@redhat.com>   0.97.3
257 - Remove debug file from files list.
258
259 * Fri Aug 13 2004 Jeff Johnston <jjohnstn@redhat.com>   0.97.2
260 - Import version 0.97.
261
262 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
263 - rebuilt
264
265 * Wed Jun 09 2004  Elena Zannoni <ezannoni@redhat.com>  0.96.4
266 - Bump release number.
267
268 * Mon Feb 23 2004  Elena Zannoni <ezannoni@redhat.com>  0.96.3
269 - Bump release number.
270
271 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
272 - rebuilt
273
274 * Thu Jan 29 2004  Jeff Johnston <jjohnstn@redhat.com>  0.96.1
275 - Import version 0.96.
276
277 * Tue Jan 06 2004  Jeff Johnston <jjohnstn@redhat.com>  0.92.2
278 - Bump release number.
279
280 * Mon Oct 06 2003  Jeff Johnston <jjohnstn@redhat.com>  0.92.1
281 - Initial release
282